Bug 1872976 - Allow the replacement when rebalancing is in progress
Summary: Allow the replacement when rebalancing is in progress
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: afrahman
QA Contact: Itzhak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-27 04:28 UTC by afrahman
Modified: 2020-10-27 16:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:34:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Rebalance warning (23.70 KB, image/png)
2020-10-22 06:16 UTC, Itzhak
no flags Details
Replacement ready (43.17 KB, image/png)
2020-10-22 06:19 UTC, Itzhak
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6549 0 None closed Bug 1872976: Allow disk replacement when rebalancing 2020-10-19 02:11:18 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:34:49 UTC

Comment 6 Itzhak 2020-10-15 16:05:32 UTC
I will try to check this bug on Monday

Comment 7 Itzhak 2020-10-19 14:14:06 UTC
Currently I don't have a cluster with vSphere LSO 4.6, so I can't test it today. 
If someone else has a cluster with the conf above let me know. 
If not, I will try to deploy a new cluster tomorrow.

Comment 8 Itzhak 2020-10-22 06:14:46 UTC
I used a Vsphere LSO 4.6 to check the bug.

Steps I did to reproduce the bug:

1. I scale down the deployment of the osd-0 by executing this command:
$oc scale deployment rook-ceph-osd-0 --replicas=0 -n openshift-storage

2. Check that only 2 OSD's are up instead of 3.

3. Go to Compute-Nodes
4. Click on Disks tab
5. Click on the kebab action of disk with "Not responding" status ->  Start disk replacement
6. Click on Replace and verify that I see the "rebalancing is in progress" warning, 
   but still, I can perform the replacement(added a screenshot). 
7. Try to click on the replace button and see that the disk can be replaced(added a screenshot). 

Additional info:

OCP version:
Client Version: 4.3.8
Server Version: 4.6.0-0.nightly-2020-10-20-172149
Kubernetes Version: v1.19.0+d59ce34

OCS verison:
ocs-operator.v4.6.0-134.ci   OpenShift Container Storage   4.6.0-134.ci              Succeeded

cluster version
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-10-20-172149   True        False         20h     Cluster version is 4.6.0-0.nightly-2020-10-20-172149

Rook version
rook: 4.6-67.afaf3353.release_4.6
go: go1.15.0

Ceph version
ceph version 14.2.8-111.el8cp (2e6029d57bc594eceba4751373da6505028c2650) nautilus (stable)

Comment 9 Itzhak 2020-10-22 06:16:55 UTC
Created attachment 1723412 [details]
Rebalance warning

Comment 10 Itzhak 2020-10-22 06:19:55 UTC
Created attachment 1723413 [details]
Replacement ready

Comment 12 errata-xmlrpc 2020-10-27 16:34:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.