Bug 187302 - X server crashes with "Active ring not flushed" while using Firefox
X server crashes with "Active ring not flushed" while using Firefox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 16:02 EST by Micah Abbott
Modified: 2008-07-15 13:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: F8-updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 13:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.63 KB, text/plain)
2006-03-30 19:31 EST, Micah Abbott
no flags Details
Xorg.0.log (37.83 KB, text/plain)
2006-03-30 19:32 EST, Micah Abbott
no flags Details
HTML file to reproduce Xserver crash (90.00 KB, application/x-tar)
2007-07-31 18:09 EDT, Andreas Freiherr
no flags Details
xorg.conf in effect during crash (725 bytes, text/plain)
2007-07-31 18:11 EDT, Andreas Freiherr
no flags Details
Xorg.0.log of crash (38.69 KB, text/plain)
2007-07-31 18:12 EDT, Andreas Freiherr
no flags Details
Xorg.0.log after hiding xorg.conf (17.06 KB, text/plain)
2007-07-31 18:19 EDT, Andreas Freiherr
no flags Details

  None (edit)
Description Micah Abbott 2006-03-29 16:02:08 EST
Description of problem:

Intermittently, I have found that while using Firefox, my X server will crash. 
This usually happens while Firefox is loading some web page (no particular page
seems to trigger the problem).  It can be as long as a day or two after boot-up
before I see a crash or as little as 30 minutes.  

Upon inspecting Xorg.O.log, I find the following messages at the end of the file:

pgetbl_ctl: 0x1f880001 pgetbl_err: 0x2e0a000
ipeir: 0 iphdr: 50c00004
LP ring tail: 3c0 head: e0 len: f001 start 580000
eir: 0 esr: 0 emr: 3d
instdone: ff3a instpm: 0
memmode: 4 instps: 810
hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0

Fatal server error:
Active ring not flushed


Version-Release number of selected component (if applicable):
X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux dhcp-ubur03-185-194.East.Sun.COM
2.6.15-1.2054_FC5 #1 Tue Mar 14 15:48:33 EST 2006 i686
Build Date: 15 March 2006


How reproducible:
Intermittent.  Can take days or just minutes.


Steps to Reproduce:
1.  Use Firefox normally.
2.
3.
  
Actual results:
X server crashes

Expected results:
X server does not crash

Additional info:
The computer running FC5 is relatively old.  PIII @ 1 Ghz with 512 MB RAM. 
Onboard i810 graphics.
Comment 1 Mike A. Harris 2006-03-29 16:17:12 EST
The next time the problem occurs, as soon as you reboot, boot into runlevel 3
without having the X server start, and then make a backup copy of the X server
log and config file.  Attach them to bugzilla as individual uncompressed
file attachments using the link below.
Comment 2 Micah Abbott 2006-03-30 19:31:07 EST
Created attachment 127088 [details]
xorg.conf
Comment 3 Micah Abbott 2006-03-30 19:32:13 EST
Created attachment 127089 [details]
Xorg.0.log
Comment 4 Micah Abbott 2006-04-03 15:24:28 EDT
Just wanted to make a comment saying that I attached my xorg.conf and Xorg.0.log
files from a previous crash.  Don't want this bug to lose visibility...
Comment 5 Matěj Cepl 2007-04-04 18:00:01 EDT
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)?
Comment 6 Micah Abbott 2007-04-04 18:11:49 EDT
My apologies, but since reporting this bug I am no longer using the hardware on
which this bug was reported.  Additionally, I do not own said hardware either,
so I am afraid I cannot provide further information.
Comment 7 Matěj Cepl 2007-04-04 18:28:45 EDT
Per reporter's information, closing.
Comment 8 Andreas Freiherr 2007-07-30 12:15:25 EDT
Sorry to chime in and reopen (had to kludge because REOPEN was rejected), but:

- I own hardware to reproduce this problem,
- I can confirm the issue still exists in FC6 / Firefox 2.0.0.5, and
- I have a HTML file that triggers the crash reliably
  (removing one line from the file makes the page display properly, no crash)

And, of course, I would LOVE to see this fixed.

What can I do to help?
Comment 9 Matěj Cepl 2007-07-31 08:49:53 EDT
Wonderful! OK, in order to understand more what's going on, we would need the
following files (as separate uncompressed attachments to this bug report):

- of course, the HTML file for bug reproduction with the information what needs
to be removed to make it working
- /var/log/Xorg.0.log
- /etc/X11/xorg.conf

Then you should try to rename /etc/X11/xorg.conf to something else and restart
X. If you are able to reproduce the bug then, attach us new /var/log/Xorg.0.log
as well.

Thank you very much.
Comment 10 Andreas Freiherr 2007-07-31 18:09:57 EDT
Created attachment 160370 [details]
HTML file to reproduce Xserver crash

As requested, I am attaching the HTML file that I use to crash the Xserver,
plus all required images to display the page.
The crash can be avoided by deleting line 1258, which is a table cell using
file res_html/telschrift as the background image: in vi, do 1258Gdd:wq to
produce a file that can be displayed without crashing Xserver.
Comment 11 Andreas Freiherr 2007-07-31 18:11:17 EDT
Created attachment 160371 [details]
xorg.conf in effect during crash
Comment 12 Andreas Freiherr 2007-07-31 18:12:02 EDT
Created attachment 160372 [details]
Xorg.0.log of crash
Comment 13 Andreas Freiherr 2007-07-31 18:19:15 EDT
Created attachment 160374 [details]
Xorg.0.log after hiding xorg.conf

As suggested, I tried to restart X after renaming xorg.conf to xorg.conf_save
in order to reproduce the problem. Surprise: Xserver would not even start! (It
did, however, after moving xorg.conf back to where it belongs.) I doubt the
enclosed file will help with resolving this bug (it might even be a different
story on its own), but just in case...
Please let me know if anything else might be helpful.
Comment 14 Andreas Freiherr 2007-07-31 18:25:14 EDT
One more hint: if I add Option "NoAccel" to xorg.conf, the page is displayed in
Firefox with no problem. I cannot even consider this a good workaround, however,
because I want to use the same PC for Google Earth...
Do let me know if you require any additional information that I might be able to
provide.
Comment 15 Andreas Freiherr 2007-07-31 18:33:06 EDT
Another observation: I tried Driver "intel" instead of Driver "i810". Same problem.
Comment 16 Matěj Cepl 2007-08-01 12:52:39 EDT
caillon, martin -- do you have any idea, what's going on here in Firefox?
Comment 17 Andreas Freiherr 2007-08-14 12:34:31 EDT
Would it be of use to know that the Xserver does not yet crash when the page is
loaded and, presumably, rendered entirely? - Rather, the crash occurs at the
exact time when I scroll down far enough for the image in question (line 1258 as
noted above) to start becoming visible. Instead of displaying the top edge of
the image, the screen gets trashed.

I want to renew my offer to help in any way I can. Any findings so far?

Comment 18 Dave Airlie 2007-08-15 18:26:53 EDT
this sounds like something I should look into .. it's probably a bug in
composite support
Comment 19 Dave Airlie 2007-08-15 18:28:53 EDT
oh worse this is an original i810.. okay it might be more tricky to figure out..
Comment 20 Andreas Freiherr 2007-09-18 06:13:17 EDT
A little more than a month since the last notice here, and the only perceptible
change for me is that I learned about Google Earth having some nasty (but well
documented) problems with Intel chips when running on Linux. Is it time to start
looking for a non-Intel graphics board? - Any progress information that might
make it easier for me to wait?
Comment 21 Andreas Freiherr 2007-10-02 13:25:21 EDT
Another two weeks with no response at all. I'd be happy if I'd get something
like "hold on, we're busy, but will get back to you" at least. Maybe this should
be assigned to somebody who can respond more timely?
Comment 22 Matěj Cepl 2007-10-02 15:07:05 EDT
There are currently 662 bugs opened against Xorg components, sorry, we are
dancing as fast as we can, and we know very well, that is not fast enough. I am
really sorry, I hope that somebody will get to you ASAP.
Comment 23 Dave Airlie 2007-10-03 18:40:59 EDT
The problem with this bug is it requires an actual i810 machine, these are
fairly rare and quite ancient chipsets. I've got 815 machines which don't show
the bug so I cannot figure out how to fix it using the hw I have..

This doesn't happen to any other chipset so hence why we are a bit slow looking
into it...
Comment 24 Andreas Freiherr 2007-10-04 12:35:44 EDT
Thanks for the update. Should you find anything that I can try here, such as run
a debug version of the driver or some other component, with additional logging
built in, please let me know.

In case I stumble across a spare Dell GX110 with a similar motherboard: where do
you want me to send it? This might also aid in maintaining support for the older
chips.
Comment 26 Bug Zapper 2008-04-03 22:22:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 27 Andreas Freiherr 2008-04-20 07:15:13 EDT
After being prompted above, I tried to reproduce the problem. Meanwhile, I have
updated Firefox to "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11)
Gecko/20071201 Remi/2.0.0.11-1.fc6.remi Firefox/2.0.0.11", and it did not crash
upon displaying the page.

However: when I tried to report this fact here from the same Firefox session, it
crashed at the very moment when I clicked the "Save Changes" button.

So we are aiming at a moving target.

I tried to reproduce the problem with Fedora 8 (using Firefox 2.0.0.3 from the
FC7 distribution because I could not find a 2.0.0.5 RPM for FC8), but could not
find it crashing with this file. Not sure what that is worth with the recent
experience, though...

From other experience with the i810 in FC6 (e.g., glxgears scattering scan lines
of the gears across the whole display, outside the window, when a resolution of
1600x1200 is used), my wild and uneducated guess is that there may be some
addressing limit in the i810 that was lifted with later chips, like the size of
an address register in the chip, or the GART window, the size of which
apparently is hard-wired, independent of display size.

(Is that image mentioned in comment #10 loaded as a texture...?)
Comment 28 Mike Chambers 2008-05-02 23:39:38 EDT
Going to change the version of this bug to Fedora 8 and to assigned.  If the
reporter would still show what version of firefox they are using (rpm -q
firefox) and what version of Fedora you are indeed using would help a lot.  IF
you are still using Fedora 5, we will need to close this bug as it has reached
EOL and no longer maintainted.

Thank you.
Comment 29 Dave Airlie 2008-05-09 01:07:33 EDT
okay this has probably gone on too long :)

I'm wondering if you can try adding various 

Option "XaaNo*" from xorg.conf 

and seeing if it becomes stable with any of those set.

Comment 30 Andreas Freiherr 2008-06-01 10:29:45 EDT
My apologies for the late reply: my tax declaration is due in May, and German
tax law is said to be the most complicated in the world...

So, for starters, here are the answers to Mike's questions:

[andreas@test ~]$ rpm -q firefox
firefox-2.0.0.3-4.fc7
[andreas@test ~]$ uname -r
2.6.24.4-64.fc8
[andreas@test ~]$

As pointed out above, it got more difficult to reproduce the crash with FC8, but
the problem still exists, so I'd prefer to keep following up on this bug. To
make tracking the target no more difficult that it already is, I will suspend
updates and stick with the current version - unless told otherwise.

I am now setting out to play with the xorg.conf options as suggested by Dave.
This may be a tedious task, but I'll be back as soon as I have results.
Comment 31 Matěj Cepl 2008-07-01 10:41:20 EDT
Reporter, could you please reply to the previous question?
Comment 32 Micah Abbott 2008-07-01 11:08:44 EDT
As I stated in comment #6, I no longer have access to the hardware that was used
when I first reported this bug.  It appears that Andreas Freiherr is better
equipped to continue to chase down this problem.

My apologies.
Comment 33 Matěj Cepl 2008-07-02 12:43:32 EDT
I know, sorry, I meant Andreas, but automatism took over me.

Andreas?
Comment 34 Andreas Freiherr 2008-07-06 16:31:22 EDT
Matej, Dave,

As promised in my comment #30, I tried to reproduce the problem. However, for
some reason that I cannot seem to find, the crash no longer occurs with the
original sample page. It may have been fixed somewhere in the timeframe between
comment #27 and today, but Firefox crashed my FC8 once when attempting to read a
new message at "my Ebay" with the exact same symptoms.

I am going to upgrade the PC with this i810 chipset to FC8 for routine operation
soon (was bound to FC6 in order to allow me VPN access to my employer's
network). Until I find another page that demonstrates the problem, it is
probably better to close this bug. I can still open it again when I have proper
evidence, right?

Thanks for bearing with me!
Andreas
Comment 35 Matěj Cepl 2008-07-15 13:05:21 EDT
Of course you can. Or just adding a comment here should get to me as well.

Note You need to log in before you can comment on or make changes to this bug.