Bug 1873029 - bugs can't be reported: "No matching actions found for this event"
Summary: bugs can't be reported: "No matching actions found for this event"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: BetaBlocker, F33BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-08-27 08:11 UTC by Kamil Páral
Modified: 2020-09-21 20:48 UTC (History)
15 users (show)

Fixed In Version: libreport-2.14.0-8.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 20:48:44 UTC
Type: Bug


Attachments (Terms of Use)
example error message (43.11 KB, image/png)
2020-08-27 08:12 UTC, Kamil Páral
no flags Details
example error message #2 (45.54 KB, image/png)
2020-08-27 08:12 UTC, Kamil Páral
no flags Details
example error message #3 (40.87 KB, image/png)
2020-08-27 08:13 UTC, Kamil Páral
no flags Details
screenshot (102.61 KB, image/png)
2020-09-11 20:43 UTC, Chris Murphy
no flags Details

Description Kamil Páral 2020-08-27 08:11:46 UTC
Description of problem:
After installing https://bodhi.fedoraproject.org/updates/FEDORA-2020-59e144acee to resolve bug 1860616 , I can't report a single crash. Whether I try something from will-crash package, or whether I kill a random app with kill -ABRT, the reporting always ends with

> --- Skipping XXX ---
> No matching actions found for this event.

Replace XXX with a random string, something making sense (like "Bugzilla" or "mountinfo", sometimes displayed as random characters). Each time I retry the Report action (both on different, but even on the *same* crash), XXX changes to something else.


Version-Release number of selected component (if applicable):
abrt-2.14.4-2.fc33.x86_64
abrt-addon-ccpp-2.14.4-2.fc33.x86_64
abrt-addon-kerneloops-2.14.4-2.fc33.x86_64
abrt-addon-pstoreoops-2.14.4-2.fc33.x86_64
abrt-addon-vmcore-2.14.4-2.fc33.x86_64
abrt-addon-xorg-2.14.4-2.fc33.x86_64
abrt-cli-2.14.4-2.fc33.x86_64
abrt-dbus-2.14.4-2.fc33.x86_64
abrt-desktop-2.14.4-2.fc33.x86_64
abrt-gui-2.14.4-2.fc33.x86_64
abrt-gui-libs-2.14.4-2.fc33.x86_64
abrt-java-connector-1.2.0-2.fc33.x86_64
abrt-libs-2.14.4-2.fc33.x86_64
abrt-plugin-bodhi-2.14.4-2.fc33.x86_64
abrt-retrace-client-2.14.4-2.fc33.x86_64
abrt-tui-2.14.4-2.fc33.x86_64
gnome-abrt-1.3.6-2.fc33.x86_64
libreport-2.14.0-4.fc33.x86_64
libreport-anaconda-2.14.0-4.fc33.x86_64
libreport-cli-2.14.0-4.fc33.x86_64
libreport-fedora-2.14.0-4.fc33.x86_64
libreport-filesystem-2.14.0-4.fc33.noarch
libreport-gtk-2.14.0-4.fc33.x86_64
libreport-plugin-bugzilla-2.14.0-4.fc33.x86_64
libreport-plugin-kerneloops-2.14.0-4.fc33.x86_64
libreport-plugin-logger-2.14.0-4.fc33.x86_64
libreport-plugin-reportuploader-2.14.0-4.fc33.x86_64
libreport-plugin-systemd-journal-2.14.0-4.fc33.x86_64
libreport-plugin-ureport-2.14.0-4.fc33.x86_64
libreport-web-2.14.0-4.fc33.x86_64
python3-abrt-2.14.4-2.fc33.x86_64
python3-abrt-addon-2.14.4-2.fc33.noarch
python3-libreport-2.14.0-4.fc33.x86_64
satyr-0.31-2.fc33.x86_64

How reproducible:
always

Steps to Reproduce:
1. update to https://bodhi.fedoraproject.org/updates/FEDORA-2020-59e144acee
2. reboot
3. install will-crash
4. run will_abort or will_cpp_segfault
5. try to report the bug
6. see the error message, no bug is reported

Comment 1 Kamil Páral 2020-08-27 08:12:47 UTC
Created attachment 1712782 [details]
example error message

Comment 2 Kamil Páral 2020-08-27 08:12:55 UTC
Created attachment 1712783 [details]
example error message #2

Comment 3 Kamil Páral 2020-08-27 08:13:05 UTC
Created attachment 1712784 [details]
example error message #3

Comment 4 Kamil Páral 2020-08-27 08:15:33 UTC
Proposing as a BetaBlocker using the same argument as in bug 1860616 comment 8:
"Bug hinders execution of required Beta test plans or dramatically reduces test coverage"

Comment 5 Ernestas Kulik 2020-08-27 10:50:21 UTC
Which reporting frontend are you using? Sounds like report-gtk and https://github.com/abrt/libreport/commit/85b687098bcedb67285ab787b8bd506d328c34e0.

Comment 6 Kamil Páral 2020-08-27 13:47:07 UTC
I don't know, you have more of them? :) Whichever one is the preinstalled one in Workstation. Doesn't the screenshot help to answer that?

Comment 7 Michael Catanzaro 2020-08-27 13:55:26 UTC
Kamil, were you able to report anything before this update?

We've been tracking https://pagure.io/fedora-workstation/issue/156 since the retrace server is down and manual reporting process depends on that.

Comment 8 Kamil Páral 2020-08-27 13:58:39 UTC
(In reply to Michael Catanzaro from comment #7)
> Kamil, were you able to report anything before this update?

No, I wasn't, because of bug 1860616. But on my F32, I'm not able to report anything because FAF is down and ABRT doesn't want to proceed without it. I intend to report it against F33 and propose it as a blocker, but I first need to confirm it actually happens on F33. And so far, I've been blocked by bug 1860616 and this bug. Once that is resolved and I can progress further, I'll report another bug regarding FAF, if needed.

Comment 9 Michael Catanzaro 2020-08-30 15:31:34 UTC
(In reply to Kamil Páral from comment #8)
> No, I wasn't, because of bug 1860616. But on my F32, I'm not able to report
> anything because FAF is down and ABRT doesn't want to proceed without it. I
> intend to report it against F33 and propose it as a blocker, but I first
> need to confirm it actually happens on F33. And so far, I've been blocked by
> bug 1860616 and this bug. Once that is resolved and I can progress further,
> I'll report another bug regarding FAF, if needed.

You might want to also follow https://pagure.io/fedora-workstation/issue/156 and https://pagure.io/fedora-workstation/issue/130. If ABRT can be made functional again in F33 timeframe, that would be great. Otherwise... well, I don't think we want to delay release on it....

Comment 10 Adam Williamson 2020-08-31 15:57:36 UTC
We have +4 in the ticket:
https://pagure.io/fedora-qa/blocker-review/issue/45

so setting accepted. I do care about the "update hasn't gone stable" point, but it seems reasonable to accept this as a blocker to try and ensure we don't push an update stable with this bug in it.

Comment 11 Chris Murphy 2020-09-11 20:43:48 UTC
Created attachment 1714606 [details]
screenshot

I'm not seeing this; instead I see the processing failed message.

Comment 12 Chris Murphy 2020-09-11 21:05:32 UTC
I cropped that image tightly, but I am not given an option to process the stack trace locally.

Comment 13 Adam Williamson 2020-09-11 21:12:59 UTC
Chris: was that with a newly-generated crash? Apparently you still can't report crashes for which the directory was created before the ztsd-supporting update even after you update. You have to cause a new crash after updating and try reporting that.

Comment 14 Chris Murphy 2020-09-11 22:40:40 UTC
It was a new crash.

Comment 15 Chris Murphy 2020-09-11 23:04:08 UTC
Decided to file a new bug since my case looks different from this one; bug 1878317.

Comment 16 Brandon Nielsen 2020-09-12 23:46:02 UTC
I see this with 20200912.n.0 compose with FEDORA-2020-59e144acee applied.

Steps to reproduce:

1) Install Workstation Live 20200912.n.0
2) `$ bodhi updates download --updateid=FEDORA-2020-59e144acee`
3) `$ sudo dnf install ./*`
3) Reboot
4) `$ will_abort`
5) Step through steps to submit report, observe "No matching actions" error in gnome-abrt.

Comment 17 Kamil Páral 2020-09-15 07:15:23 UTC
This seems to be fixed with this update:
https://bodhi.fedoraproject.org/updates/FEDORA-2020-444a3363f0
meaning:
abrt-2.14.4-5.fc33.x86_64
gnome-abrt-1.3.6-5.fc33.x86_64
libreport-2.14.0-8.fc33.x86_64

However, that update still causes bug 1878317, so it's not clear whether it'll get pushed stable.

Comment 18 Fedora Update System 2020-09-15 22:30:50 UTC
FEDORA-2020-444a3363f0 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-444a3363f0

Comment 19 Fedora Update System 2020-09-15 22:31:04 UTC
FEDORA-2020-444a3363f0 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-444a3363f0

Comment 20 Fedora Update System 2020-09-16 18:55:58 UTC
FEDORA-2020-444a3363f0 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-444a3363f0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-444a3363f0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2020-09-21 20:48:44 UTC
FEDORA-2020-444a3363f0 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.