Bug 1873188 - mopac7 FTBFS with LTO
Summary: mopac7 FTBFS with LTO
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mopac7
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Law
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1789115
TreeView+ depends on / blocked
 
Reported: 2020-08-27 15:04 UTC by Mamoru TASAKA
Modified: 2020-08-27 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-27 16:38:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Mamoru TASAKA 2020-08-27 15:04:48 UTC
Description of problem:
mopac7 FTBFS with LTO. Currently to avoid FTBFS, LTO is disabled.

Version-Release number of selected component (if applicable):
mopac7-1.15-34.fc33

How reproducible:
100%

Steps to Reproduce:
1. modify mopac7.spec to enable LTO again: https://src.fedoraproject.org/rpms/mopac7
2. build
3.

Actual results:
FTBFS on some archs: https://koji.fedoraproject.org/koji/taskinfo?taskID=50252140

Expected results:
Build succeeds, or some code mistakes on mopac7 are found.


Additional info:

Comment 1 Mamoru TASAKA 2020-08-27 15:05:42 UTC
Once setting assignee to Jeff to ask for help.

Comment 2 Jeff Law 2020-08-27 16:38:06 UTC
Thanks.  You've done the right thing by opting out of LTO for now.  Because you used a standard opt-out my scanner has already flagged mopac7 for deeper analysis -- at first glance I suspect we've dropped a PIC or are mixing PIC and PIE.  THe latter in particular has caused problems in a few packages as we've enabled LTO.  I won't know for sure until I dig into it further.

Given you're using a standard opt-out and thus my scanner has it flagged for deeper analysis and the immediate FTBFS issue is worked around we can close this BZ.


Note You need to log in before you can comment on or make changes to this bug.