Bug 187320 - glibc update has network problems
glibc update has network problems
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 18:51 EST by Bob T.
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 08:22:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob T. 2006-03-29 18:51:45 EST
Description of problem: yum and ncftp fail in bizarre ways (seg faults, unable
to download files).  The problems disappear when I revert to 
2.3.5-10

Version-Release number of selected component (if applicable):2.3.6-3


How reproducible: The problems seem to vary from one system to another. If a
problem exists on a system, it happens consistently.


Steps to Reproduce:
1. yum update 
or start up ncftp
2.
3.
  
Actual results: errors, seg faults, hangs, etc.  never observed previously


Expected results:


Additional info: problems disappear when I revert to older version
Comment 1 Jakub Jelinek 2006-03-30 02:57:36 EST
Do you have nisplus in /etc/nsswitch.conf?
Does removing all nisplus keywords from it fix this?
If so, this would be a dup of #186592 and as a workaround, unless you really need
to use NIS+ is just to remove nisplus from nsswitch.conf.
Comment 2 Bob T. 2006-03-30 07:42:30 EST
 >Do you have nisplus in /etc/nsswitch.conf?  

Yes. Not because I put it there; that file dates back to Sep 13  2002 (a Friday
no doubt). I don't recall ever touching it.

>Does removing all nisplus keywords from it fix this?  

Some of the entries have nisplus only:

netgroup:   nisplus
publickey:  nisplus

What do I do with those?  I'm not keen on experimenting. I may have to revert
back to 2.3.5 again and on one system here downgrading left the box without a
working ld. Can I use the nsswitch.conf.rpmnew installed March 19, 2003? I
suggest you post a complete nsswitch.conf that works with 2.3.6.  I don't think
I really need NIS+; I don't even know what it is.
Comment 3 Jakub Jelinek 2006-03-30 07:50:37 EST
Can you
grep nisplus /etc/nsswitch.conf
or attach your whole nsswitch.conf here?
What really matters is if none of passwd, shadow, group or hosts contain nisplus
keyword.
My nsswitch.conf has (other than comments):
passwd:     files
shadow:     files
group:      files
hosts:      files dns
bootparams: files
ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files
netgroup:   nisplus
publickey:  nisplus
automount:  files
aliases:    files
Comment 4 Bob T. 2006-03-30 08:19:25 EST
passwd:     files nisplus
shadow:     files nisplus
group:      files nisplus

hosts:      files nisplus dns
  

bootparams: nisplus [NOTFOUND=return] files

ethers:     files
netmasks:   files
networks:   files
protocols:  files nisplus
rpc:        files
services:   files nisplus

netgroup:   files nisplus

publickey:  nisplus

automount:  files nisplus
aliases:    files nisplus

Comment 5 Jakub Jelinek 2006-03-30 08:22:17 EST
Removing nisplus from the first 4 lines should be enough.

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.