Bug 1873414 - [openshift-console].container[download-server]=/bin/sh: line 110: exec: python2: not found
Summary: [openshift-console].container[download-server]=/bin/sh: line 110: exec: pytho...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: Justin Pierce
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-28 09:00 UTC by Michal Fojtik
Modified: 2020-10-27 16:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:35:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 463 0 None closed Bug 1873414: Move deployment script to python3 2020-09-27 07:00:04 UTC
Github openshift images pull 34 0 None closed Bug 1873414: Install python3 in ubi8 base to emulate ubi7 2020-09-27 07:00:04 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:35:51 UTC

Description Michal Fojtik 2020-08-28 09:00:51 UTC
Description of problem:

The e2e-aws is broken due to:

Aug 28 03:13:18.826: INFO: downloads-df9d756d5-2zhwf[openshift-console].container[download-server]=/bin/sh: line 110: exec: python2: not found

Aug 28 03:13:18.826: INFO: downloads-df9d756d5-qcvgk[openshift-console].container[download-server]=/bin/sh: line 110: exec: python2: not found

The container is crahslooping.

Found in https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_cluster-etcd-operator/431/pull-ci-openshift-cluster-etcd-operator-master-e2e-aws/1299164738214694912


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Jakub Hadvig 2020-08-28 09:18:22 UTC
Assigning to the release team, since the python2 is not being found in the download pod which is using the `registry.svc.ci.openshift.org/openshift:cli-artifacts` image.
Checked the `download` pod in 4.6.0-0.nightly-2020-08-27-005538 cluster version and the python2 is there available.

Comment 9 errata-xmlrpc 2020-10-27 16:35:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.