Bug 1873424 - Bios boot device is provisioned when devicetype is part
Summary: Bios boot device is provisioned when devicetype is part
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Rohan CJ
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-28 09:54 UTC by Chao Yang
Modified: 2020-10-27 16:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:35:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 156 0 None closed Bug 1873424: Bios boot device is provisioned when devicetype is part 2020-11-12 12:14:35 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:35:51 UTC

Description Chao Yang 2020-08-28 09:54:43 UTC
Description of problem:
Bios boot device is provisioned when devicetype is part

Version-Release number of selected component (if applicable):
local-storage-operator.4.6.0-202008270726.p0
4.6.0-0.nightly-2020-08-27-005538

How reproducible:
Always

Steps to Reproduce:
1.Deploy Local-storage-operator
2.Create localvolumeset instance lvs-part
oc get localvolumeset lvs-part -o yaml
apiVersion: local.storage.openshift.io/v1alpha1
kind: LocalVolumeSet
metadata:
  creationTimestamp: "2020-08-28T08:57:56Z"
  generation: 2
  managedFields:
  - apiVersion: local.storage.openshift.io/v1alpha1
    fieldsType: FieldsV1
    fieldsV1:
      f:spec:
        .: {}
        f:deviceInclusionSpec:
          .: {}
          f:deviceTypes: {}
        f:maxDeviceCount: {}
        f:nodeSelector:
          .: {}
          f:nodeSelectorTerms: {}
        f:storageClassName: {}
        f:volumeMode: {}
    manager: oc
    operation: Update
    time: "2020-08-28T09:02:18Z"
  - apiVersion: local.storage.openshift.io/v1alpha1
    fieldsType: FieldsV1
    fieldsV1:
      f:spec:
        f:deviceInclusionSpec:
          f:minSize: {}
      f:status:
        .: {}
        f:conditions: {}
        f:observedGeneration: {}
        f:totalProvisionedDeviceCount: {}
    manager: local-storage-operator
    operation: Update
    time: "2020-08-28T09:02:27Z"
  name: lvs-part
  namespace: openshift-local-storage
  resourceVersion: "319822"
  selfLink: /apis/local.storage.openshift.io/v1alpha1/namespaces/openshift-local-storage/localvolumesets/lvs-part
  uid: dd99b4f8-fad6-4cee-81f3-b0cf14ca8fb2
spec:
  deviceInclusionSpec:
    deviceTypes:
    - part
    minSize: 0Ti
  maxDeviceCount: 2
  nodeSelector:
    nodeSelectorTerms:
    - matchExpressions:
      - key: kubernetes.io/hostname
        operator: In
        values:
        - ip-10-0-199-201
  storageClassName: lvs-part
  volumeMode: Filesystem
status:
  conditions:
  - lastTransitionTime: "2020-08-28T08:57:56Z"
    message: 'DiskMaker: Available, LocalProvisioner: Available'
    status: "True"
    type: DaemonSetsAvailable
  - lastTransitionTime: "2020-08-28T08:57:56Z"
    message: Operator reconciled successfully.
    status: "True"
    type: Available
  observedGeneration: 2
  totalProvisionedDeviceCount: 4

3.Check pv, found Bios boot device is provisoned.

Device           Start       End   Sectors   Size Type
/dev/nvme0n1p1    2048    788479    786432   384M Linux filesystem
/dev/nvme0n1p2  788480   1048575    260096   127M EFI System
/dev/nvme0n1p3 1048576   1050623      2048     1M BIOS boot
/dev/nvme0n1p4 1050624 251658206 250607583 119.5G Linux filesystem

lsblk
NAME                         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
nvme0n1                      259:0    0   120G  0 disk 
|-nvme0n1p1                  259:1    0   384M  0 part /boot
|-nvme0n1p2                  259:2    0   127M  0 part /boot/efi
|-nvme0n1p3                  259:3    0     1M  0 part 
`-nvme0n1p4                  259:4    0 119.5G  0 part 
  `-coreos-luks-root-nocrypt 253:0    0 119.5G  0 dm   /sysroot


oc get pv local-pv-7f30c30 -o yaml
apiVersion: v1
kind: PersistentVolume
metadata:
  annotations:
    pv.kubernetes.io/provisioned-by: local-volume-provisioner-ip-10-0-199-201.us-east-2.compute.internal-3a02df77-8c95-426b-a1b4-5abd9205a864
  creationTimestamp: "2020-08-28T08:58:17Z"
  finalizers:
  - kubernetes.io/pv-protection
  labels:
    kubernetes.io/hostname: ip-10-0-199-201
  managedFields:
  - apiVersion: v1
    fieldsType: FieldsV1
    fieldsV1:
      f:status:
        f:phase: {}
    manager: kube-controller-manager
    operation: Update
    time: "2020-08-28T08:58:17Z"
  - apiVersion: v1
    fieldsType: FieldsV1
    fieldsV1:
      f:metadata:
        f:annotations:
          .: {}
          f:pv.kubernetes.io/provisioned-by: {}
        f:labels:
          .: {}
          f:kubernetes.io/hostname: {}
      f:spec:
        f:accessModes: {}
        f:capacity:
          .: {}
          f:storage: {}
        f:local:
          .: {}
          f:path: {}
        f:nodeAffinity:
          .: {}
          f:required:
            .: {}
            f:nodeSelectorTerms: {}
        f:persistentVolumeReclaimPolicy: {}
        f:storageClassName: {}
        f:volumeMode: {}
    manager: local-provisioner
    operation: Update
    time: "2020-08-28T08:58:17Z"
  name: local-pv-7f30c30
  resourceVersion: "315991"
  selfLink: /api/v1/persistentvolumes/local-pv-7f30c30
  uid: 86d2fab1-11c2-408a-8527-23fd51a5d804
spec:
  accessModes:
  - ReadWriteOnce
  capacity:
    storage: 1Mi
  local:
    path: /mnt/local-storage/lvs-part/nvme-Amazon_Elastic_Block_Store_vol0d2689d64ec9734a2-part3
  nodeAffinity:
    required:
      nodeSelectorTerms:
      - matchExpressions:
        - key: kubernetes.io/hostname
          operator: In
          values:
          - ip-10-0-199-201
  persistentVolumeReclaimPolicy: Delete
  storageClassName: lvs-part
  volumeMode: Filesystem
status:
  phase: Available

4.Check localvolumediscoveryresult
  Discovered Devices:
    Device ID:  /dev/disk/by-id/nvme-Amazon_Elastic_Block_Store_vol0d2689d64ec9734a2-part3
    Fstype:     
    Model:      
    Path:       /dev/nvme0n1p3
    Property:   NonRotational
    Serial:     
    Size:       1048576
    Status:
      State:    NotAvailable


Actual results:
Bios boot device is provisoned.

Expected results:
Bios boot device should not ve provisioned.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 4 Chao Yang 2020-10-09 07:59:22 UTC
Create localvolumeset as 
  spec:
    deviceInclusionSpec:
      deviceMechanicalProperties:
      - NonRotational
      deviceTypes:
      - disk
      - part
      minSize: 0Ti

No pv is provisioned for /dev/nvme0n1p3

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-10-08-210814   True        False         5h24m   Cluster version is 4.6.0-0.nightly-2020-10-08-210814
oc get csv
NAME                                           DISPLAY         VERSION                 REPLACES   PHASE
local-storage-operator.4.6.0-202010061132.p0   Local Storage   4.6.0-202010061132.p0              Succeeded

Comment 6 errata-xmlrpc 2020-10-27 16:35:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.