Bug 187352 - gnome-settings-daemon cannot start (shows an error and exits)
gnome-settings-daemon cannot start (shows an error and exits)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 06:47 EST by Kapoios Kanenas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 03:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-settings-daemon error message (24.64 KB, image/png)
2006-03-30 06:47 EST, Kapoios Kanenas
no flags Details

  None (edit)
Description Kapoios Kanenas 2006-03-30 06:47:48 EST
Description of problem:

gnome-settings-daemon cannot start (shows an error message and exits)
(see attachment)

On a 32bit system it works ok.

Version-Release number of selected component (if applicable):
rpmquery control-center
control-center-2.14.0-1

How reproducible:

Always. Tried with my account and a new account, in fail safe gnome but the
error persists.

Steps to Reproduce:

Not sure how this problem came to be but I assume :

After upgrading to FC5 from FC4 it worked ok till :

1. While trying to remove accessibility packages with pirut I accidently removed
control-center and gnome-session. 

2. From KDE I reinstalled them 

3. In gnome the gnome-settings-daemon error message showed and my font and icon
settings where ignored.

4. did a groupinstall "GNOME... " but didn't help

5. Removed and reinstalled control-center and libxklavier but it didn't help.

6. Set the XKB information manually in xorg.conf didn't help but I could write
in greek.


  
Actual results:

See attached error message (from fail safe gnome in a clean account )

Expected results:

not this error.

Additional info:

If I try to start gnome-settings-daemon from the command line (not sure if this
is how is supposed to run ) it fails with :


/usr/libexec/gnome-settings-daemon
--oaf-activate-iid=OAFIID:GNOME_SettingsDaemon --oaf-ior-fd=25
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 2671 error_code 2 request_code 116 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1143719502,000,xklavier.c:XklStartListen/]     The backend does not require
manual layout management - but it is provided by the application
Comment 1 Kapoios Kanenas 2006-03-30 06:47:48 EST
Created attachment 127049 [details]
gnome-settings-daemon error message
Comment 2 Kapoios Kanenas 2006-04-01 03:05:46 EST
Ok it has nothing to do with the reinstallation of the packages.

it is the evdev driver for my mx510 mouse. When I use it I gnome-settings-daemon
cannot start. 
When I use the mouse driver in xorg.conf it works ok (except my buttons :() 

evdev config, gnome-settings-daemon does not work :
Section "InputDevice"
        Identifier  "MX500"
        Driver      "evdev"
        Option      "Dev Phys" "usb-0000:00:02.0-1/input0"
        Option      "Dev Name" "Logitech USB-PS/2 Optical Mouse"
        Option      "Device" "/dev/input/event1"
EndSection


mouse config gnome-settings-daemon works :

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "Buttons" "10"
        Option      "ZAxisMapping" "9 10"
        Option      "Resolution" "800"
        Option      "Emulate3Buttons" "no"
EndSection
Comment 3 Kapoios Kanenas 2006-04-01 05:06:05 EST
It will be probably be fixed upstream :

http://bugzilla.gnome.org/show_bug.cgi?id=323724

Will try the patch.
Comment 4 Kapoios Kanenas 2006-04-20 03:53:29 EDT
The patch worked ok so does the new control-center-2.14.1-1.fc5.2.

Note You need to log in before you can comment on or make changes to this bug.