Bug 187356 - Subversion checkout on NFS-mounted filesystem fails
Subversion checkout on NFS-mounted filesystem fails
Status: CLOSED DUPLICATE of bug 186142
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Staubach
Brian Brock
: Regression
Depends On: 186142
Blocks: 190690 191249 198694
  Show dependency treegraph
Reported: 2006-03-30 07:44 EST by Ole Holm Nielsen
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-12 16:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ole Holm Nielsen 2006-03-30 07:44:44 EST
Description of problem:
In an NFS mounted directory we are not able to checkout from an svn (subversion)

$ svn checkout http://svn.berlios.de/svnroot/repos/gridpaw/trunk gpaw
svn: REPORT request failed on '/svnroot/repos/gridpaw/!svn/vcc/default'
svn: REPORT of '/svnroot/repos/gridpaw/!svn/vcc/default': 400 Bad Request

This is with the latest kernel (2.6.9-34.ELsmp).  With the previous kernel
(2.6.9-22.0.2.ELsmp) there is no problem (verified by booting to the older kernel).

Checking out to a local harddisk works fine.  If such a svn-copy is moved from
local disc to an NFS mounted directory, then then operations such as "svn -qu
status" fails with the same error as above. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Mount NFS filesystem from UNIX NFS-server.
2. Change directory to the NFS filesystem as an ordinary user.
3. Run "svn checkout" as shown above.
4. Change directory to a local harddisk (/dev/hda), and "svn checkout" works fine.
Actual results:
Error message from svn (shown above).

Expected results:
An svn checkout should occur normally.

Additional info:
The NFS fileserver is running HP Tru64 UNIX v5.1B (with latest patch kit).
With a Redhat Linux NFS server there is no problem.  So the problem
introduced in kernel-smp-2.6.9-34.EL is specific to non-Linux NFS servers.

The problem is also specific to using the "svn" command with
kernel-smp-2.6.9-34.EL.  All other operations on the Tru64 UNIX NFS fileserver
is working without problems.
Comment 1 Bastien Nocera 2006-05-16 10:43:54 EDT
This looks like it's already fixed in the U4 beta kernels. Would still need to
be documented in the Release notes.
Comment 11 Achim Dreyer 2006-07-21 11:10:19 EDT
Adding this as Blocker per Comment #7 - customer is waiting for this to 
work again since it broke when updating from U2 to U3.
Comment 12 Ole Holm Nielsen 2006-08-25 04:34:42 EDT
I tested this bug again on the new RHEL4 U4 running kernel 2.6.9-42.0.2.ELsmp.
The bug has not been corrected for NFS-mounted filesystems:
# svn checkout http://svn.berlios.de/svnroot/repos/gridpaw/trunk gpaw
svn: REPORT request failed on '/svnroot/repos/gridpaw/!svn/vcc/default'
svn: REPORT of '/svnroot/repos/gridpaw/!svn/vcc/default': 400 Bad Request

So apparently the bug wasn't fixed in the U4 kernels after all :-(
Comment 13 Bastien Nocera 2006-08-25 05:18:10 EDT
Indeed, the patch which actually fixes that problem, in bug #186142, was not
deemed good enough to go in RHEL4.4.
Comment 16 Ole Holm Nielsen 2006-10-13 03:03:40 EDT
Please permit my account to see the duplicate bug 186142 (I'm rejected).
When my bug 187356 has been closed as a duplicate of 186142,
then my account should automatically gain permission to view also 186142.
Isn't this a bug (or RFE) regarding Bugzilla itself ?

Note You need to log in before you can comment on or make changes to this bug.