Bug 187357 - build fails on sparc due to missing file and small changes to spec
build fails on sparc due to missing file and small changes to spec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 07:50 EST by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 01:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file enabling sparc to build (1.21 KB, patch)
2006-03-30 07:50 EST, Dennis Gilmore
no flags Details | Diff
Missing header from tarball (2.10 KB, text/plain)
2006-03-30 07:51 EST, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2006-03-30 07:50:24 EST
Description of problem: 
xorg-x11-server build fails  on sparc 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
always 
 
Steps to Reproduce: 
1.build on sparc 
2. 
3. 
   
Actual results: 
fails  due to missing header file from tarball 
 
Expected results: 
build to succedd 
 
Additional info:
Comment 1 Dennis Gilmore 2006-03-30 07:50:24 EST
Created attachment 127050 [details]
patch  to spec file enabling sparc  to build
Comment 2 Dennis Gilmore 2006-03-30 07:51:52 EST
Created attachment 127051 [details]
Missing header from tarball
Comment 3 Mike A. Harris 2006-05-19 01:14:18 EDT
The 9.FC5.3 build contains fix for this, slightly modified.

I also enabled alpha support at the same time.  We can't be going around
enabling sparc support here and there without putting alpha support
just before it in the list!  ;oP

Comment 4 Mike A. Harris 2006-05-19 01:17:31 EDT
<mharris> Ok, fixes checked into CVS for FC5
<mharris> Isn't this fixed in Xorg CVS for 7.1?
<mharris> If so, we don't need to worry about rawhide as it'll either be fixed
there already, or will be for 7.1
<dgilmore> I think it is fixed upstream

If it turns out to be present, just file a new one for rawhide later..

So the fix is in CVS, and will hit the next FC5 X server update release.

Note You need to log in before you can comment on or make changes to this bug.