Bug 18736 - agpgart fails to load
Summary: agpgart fails to load
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-09 19:30 UTC by aaldinge
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 02:20:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description aaldinge 2000-10-09 19:30:05 UTC
The supplied agpgart module fails to load.  Modprobe reports "device busy 
or missing error".  Problem occurs on i815 chipset with on board video 
disabled and geforce 2 in agp slot.  lsmod indicates the driver was not 
previously loaded.

Comment 1 Ryan Dietrich 2000-11-13 06:33:34 UTC
I'd like to confirm this bug.  I have the exact same setup.   The problem lies
in agpgart_be.c at line 2255 ... This kernel module seems only capable of
addressing the onboard video driver, and not
the agp 4x port on the motherboard.   Terribly depressing since the 815e chipset
minus the onboard video was only very recently released...

Anyone know where we can get a newer version of agpgart_be.c ? 

-Ryan Dietrich


Comment 2 Arjan van de Ven 2001-01-15 17:09:33 UTC
In 2.2.16-22 (the 7.0 kernel), the 815 chipset is not yet supported.
If/when there is going to be an kernel-eratum, it will be supported.

Comment 3 Mogens Kjaer 2001-01-17 15:46:49 UTC
The agpgart_be.c needs only a few lines of changing to make it work.
I've tried it on an IBM NetVista NGC machine, and agpgart actually loads
afterwards, but there are other problems with this machine that makes
it impossible to run Linux with DRI support on it (just to warn if someone tries
it).

A patch can be found from the linux kernel mailing list:

http://www.uwsg.indiana.edu/hypermail/linux/kernel/0101.1/0861.html


Note You need to log in before you can comment on or make changes to this bug.