Bug 187362 - x86_64 valgrind can't debug 64-bit programs
x86_64 valgrind can't debug 64-bit programs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 09:24 EST by Tethys
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.1.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 10:44:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2006-03-30 09:24:07 EST
Description of problem:
valgrind in FC4 is built for i386, and so doesn't work for 64-bit binaries.

Version-Release number of selected component (if applicable):
valgrind-2.4.0-2

How reproducible:
Every time

Steps to Reproduce:
1. valgrind ls   or   valgrind ./a.out  etc
2.
3.
  
Actual results:
mrburns:~% valgrind ls
valgrind: wrong executable class (eg. 32-bit instead
valgrind: of 64-bit)
valgrind: do_exec(/bin/ls) failed: Exec format error

Expected results:


Additional info:
It looks like this has been fixed for FC5, but for various reasons, I'm not
in a position to upgrade yet.
Comment 1 Jakub Jelinek 2006-03-30 10:44:07 EST
There are no plans to put this into FC4, the upgrade from 2.4.0 to 3.1.0
is just too invasive and 2.4.0 doesn't support x86_64 nor ppc.
You can rebuild the src.rpm yourself if you want.

Note You need to log in before you can comment on or make changes to this bug.