Bug 1873681 - Making Design-Suite Labs available for Fedora 33 Beta
Summary: Making Design-Suite Labs available for Fedora 33 Beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Cotton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-08-29 04:29 UTC by Luya Tshimbalanga
Modified: 2020-09-06 18:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-31 20:08:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Luya Tshimbalanga 2020-08-29 04:29:37 UTC
Description of problem:
Due to a conflicting library cause breaking in a package, Design Suite Labs  failed to build at this time of August 28. The fix (https://pagure.io/fedora-kickstarts/blob/f33/f/fedora-live-design_suite.ks) is in but the updated package i.e. Blender is in testing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.

Actual results:
Livemedia  failed to buid

Expected results:
Design Suite Labs Media is built

Additional info:
See https://koji.fedoraproject.org/koji/taskinfo?taskID=50314339

Comment 1 Fedora Blocker Bugs Application 2020-08-29 04:31:41 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user luya using the blocker tracking app because:

 Some packages causing Design Suite Lab to fail to build are temporarily removed for Beta release. Blender just got fixed but is currently on repo testing at the time of writing.

Comment 2 Kamil Páral 2020-08-31 12:32:57 UTC
Please link the actual fixed package that is needed, i.e. a link to Bodhi to the update which needs to be pushed stable. Thanks.

Comment 3 Luya Tshimbalanga 2020-08-31 15:28:29 UTC
Here is https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b111c84aa

Comment 4 Fedora Update System 2020-08-31 16:23:38 UTC
FEDORA-2020-1b111c84aa has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b111c84aa

Comment 5 Geoffrey Marr 2020-08-31 17:22:48 UTC
Discussed during the 2020-08-31 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-08-31/f33-blocker-review.2020-08-31-16.00.txt

Comment 6 Fedora Update System 2020-08-31 20:08:33 UTC
FEDORA-2020-1b111c84aa has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Luya Tshimbalanga 2020-09-02 00:26:26 UTC
It looks like composing build still failed. Ticket filed to merge the fix: https://pagure.io/fedora-kickstarts/pull-request/680

Comment 8 Luya Tshimbalanga 2020-09-06 18:35:51 UTC
Now another bug hit: https://bugzilla.redhat.com/show_bug.cgi?id=1851649


Note You need to log in before you can comment on or make changes to this bug.