Bug 187371 - kernel 2080_FC5 breaks dmraid initializing
kernel 2080_FC5 breaks dmraid initializing
Status: CLOSED DUPLICATE of bug 186842
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 11:21 EST by Dan Book
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 11:42:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Book 2006-03-30 11:21:18 EST
Description of problem:
With the kernel released with FC5, dmraid installing and booting worked
flawlessly for my NVRAID0 array. I recently updated several packages, including
the kernel, and restarted into the new kernel, hoping to be able to finally have
a decent video driver easily installable. Unfortunately, although grub still
works fine, as soon as it gets to the message "Red Hat nash version 5.0.32
starting" it outputs the errors:
device-mapper: dm-stripe: Target length not divisible by chunk size
device-mapper: reload ioctl failed: Invalid argument
And successively can't find any partitions, and kernel panics.
Booting back into the old kernel with no other changes still works fine.

Version-Release number of selected component (if applicable):
2.6.16-1.2080_FC5

How reproducible:
Always

Steps to Reproduce:
1. Install kernel 2.6.16-1.2080_FC5 on a dmraid-interfaced array
2. Attempt to boot the kernel
  
Actual results:
Kernel panic - can't load dmraid

Expected results:
Successful boot

Additional info:
I'll install the test kernel 2069 to see if it has the same issue. If you have
any easy method for obtaining the log of the boot since it isn't finding any
partitions to save the log, let me know.
Comment 1 Dan Book 2006-03-30 22:23:49 EST
Same problem with 2.6.16-1.2069_FC5
Comment 2 Yuji Tsuchimoto 2006-04-03 08:11:12 EDT
The same problem with 2.6.16-1.2084_FC5.x86_64
Comment 3 Martin Bürge 2006-04-10 08:02:01 EDT
I think that's the same probleme here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186842
Comment 4 Dan Book 2006-04-10 11:42:04 EDT
Thanks for letting me know.

*** This bug has been marked as a duplicate of 186842 ***

Note You need to log in before you can comment on or make changes to this bug.