Bug 18739 - It says please submit a full bug report
It says please submit a full bug report
Status: CLOSED DUPLICATE of bug 18166
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 15:58 EDT by Paul Johnson
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 15:58:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Johnson 2000-10-09 15:58:10 EDT
I'm trying to compile lyx-1.1.5fix1 against the xforms library provided in
RH powertools.  Make fails here.  This program did compile fine in RH 6.2.

I'm informed that the gcc folks don't want these reports about RH6.2 and
gcc2.96, so I'm sharing with you instead.

Making all in mathed
make[3]: Entering directory `/usr/local/src/lyx-1.1.5fix1/src/mathed'
/bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I.
-I../../src -I../../images -I./.
./   -isystem /usr/X11R6/include  -g -O2 -fhonor-std -c formula.C
g++ -DHAVE_CONFIG_H -I. -I. -I../../src -I../../images -I./../ -isystem
/usr/X11R6/include -g -O2
 -fhonor-std -c formula.C -o formula.o
In file included from formula.C:20:
/usr/include/g++-3/sstream:49: parse error before `&'
/usr/include/g++-3/sstream:57: semicolon missing after declaration of
`std::stringbuf'
/usr/include/g++-3/sstream:57: parse error at null character
/usr/include/g++-3/sstream: In method `std::stringbuf::stringbuf
(int)':
/usr/include/g++-3/sstream:45: class `std::stringbuf' does not have any
field named `buf'
/usr/include/g++-3/sstream:45: class `std::stringbuf' does not have any
field named `mode'
/usr/include/g++-3/sstream:46: class `std::stringbuf' does not have any
field named `rpos'
/usr/include/g++-3/sstream:46: class `std::stringbuf' does not have any
field named `bufsize'
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:57: parse error before `&'
/usr/include/g++-3/sstream:61: `mode' was not declared in this scope
/usr/include/g++-3/sstream:61: `s' was not declared in this scope
/usr/include/g++-3/sstream:62: parse error before `}'
/usr/include/g++-3/sstream:64: syntax error before `('
/usr/include/g++-3/sstream:70: parse error before `&'
/usr/include/g++-3/sstream: In function `void str (...)':
/usr/include/g++-3/sstream:72: `buf' undeclared (first use this
function)
/usr/include/g++-3/sstream:72: (Each undeclared identifier is reported
only once for each function it appears in.)
/usr/include/g++-3/sstream:72: `s' undeclared (first use this function)
/usr/include/g++-3/sstream:73: `mode' undeclared (first use this
function)
/usr/include/g++-3/sstream:75: `egptr' undeclared (first use this
function)
/usr/include/g++-3/sstream:75: `gptr' undeclared (first use this
function)
/usr/include/g++-3/sstream:75: `gbump' undeclared (first use this
function)
/usr/include/g++-3/sstream:79: `pbase' undeclared (first use this
function)
/usr/include/g++-3/sstream:79: `pptr' undeclared (first use this
function)
/usr/include/g++-3/sstream:79: `pbump' undeclared (first use this
function)
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:84: parse error before `protected'
/usr/include/g++-3/sstream:86: virtual outside class declaration
/usr/include/g++-3/sstream:87: virtual outside class declaration
/usr/include/g++-3/sstream:88: parse error before `private'
/usr/include/g++-3/sstream:90: `ios::open_mode mode' used prior to
declaration
/usr/include/g++-3/sstream:91: syntax error before `::'
/usr/include/g++-3/sstream:94: parse error before `}'
/usr/include/g++-3/sstream:100: syntax error before `('
/usr/include/g++-3/sstream:104: semicolon missing after declaration of 
`stringstreambase'
/usr/include/g++-3/sstream:104: parse error before `&'
/usr/include/g++-3/sstream:105: ISO C++ forbids defining types within
return type
/usr/include/g++-3/sstream:105: two or more data types in declaration
of `str'
/usr/include/g++-3/sstream:105: semicolon missing after declaration of
`class stringstreambase'
/usr/include/g++-3/sstream: In function `int str (...)':
/usr/include/g++-3/sstream:105: new declaration `int str (...)'
/usr/include/g++-3/sstream:71: ambiguates old declaration `void str
(...)'
/usr/include/g++-3/sstream: In function `void str (...)':
/usr/include/g++-3/sstream:106: `clear' undeclared (first use this
function)
/usr/include/g++-3/sstream:107: `_strbuf' undeclared (first use this
function)
/usr/include/g++-3/sstream:108: warning: no return statement in function
returning non-void
/usr/include/g++-3/sstream: In function `std::stringbuf *rdbuf ()':
/usr/include/g++-3/sstream:112: `__my_sb' undeclared (first use this
function)
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:114: parse error before `protected'
/usr/include/g++-3/sstream:121: parse error before `const'
/usr/include/g++-3/sstream:134: parse error before `&'
/usr/include/g++-3/sstream:136: missing ';' before right brace
/usr/include/g++-3/sstream: In method `istringstream::istringstream
(int)':
/usr/include/g++-3/sstream:132: no matching function for call to
`stringstreambase::stringstreambase (int &)'
/usr/include/g++-3/sstream:104: candidates are:
stringstreambase::stringstreambase (const stringstreambase &)
/usr/include/g++-3/sstream:104:
stringstreambase::stringstreambase ()
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:137: parse error at null character
/usr/include/g++-3/sstream:145: parse error before `&'
/usr/include/g++-3/sstream:147: missing ';' before right brace
/usr/include/g++-3/sstream: In method `ostringstream::ostringstream
(int)':
/usr/include/g++-3/sstream:143: no matching function for call to
`stringstreambase::stringstreambase (int &)'
/usr/include/g++-3/sstream:104: candidates are:
stringstreambase::stringstreambase (const stringstreambase &)
/usr/include/g++-3/sstream:104:
stringstreambase::stringstreambase ()
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:148: parse error at null character
/usr/include/g++-3/sstream:156: parse error before `&'
/usr/include/g++-3/sstream:158: missing ';' before right brace
/usr/include/g++-3/sstream: In method `stringstream::stringstream
(int)':
/usr/include/g++-3/sstream:154: no matching function for call to
`stringstreambase::stringstreambase (int &)'
/usr/include/g++-3/sstream:104: candidates are:
stringstreambase::stringstreambase (const stringstreambase &)
/usr/include/g++-3/sstream:104:
stringstreambase::stringstreambase ()
/usr/include/g++-3/sstream: At top level:
/usr/include/g++-3/sstream:159: parse error at null character
/usr/include/g++-3/sstream:163: no `int std::stringbuf::sync ()' member
function declared in class `std::stringbuf'
/usr/include/g++-3/sstream: In method `int std::stringbuf::sync ()':
/usr/include/g++-3/sstream:167: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[3]: *** [formula.lo] Error 1
make[3]: Leaving directory `/usr/local/src/lyx-1.1.5fix1/src/mathed'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/lyx-1.1.5fix1/src'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/usr/local/src/lyx-1.1.5fix1/src'
make: *** [all-recursive] Error 1
Comment 1 Jakub Jelinek 2000-10-11 05:21:05 EDT

*** This bug has been marked as a duplicate of 18166 ***

Note You need to log in before you can comment on or make changes to this bug.