Bug 187403 - compat_ioctl() file op not fully backported into RHEL 4 kernel
compat_ioctl() file op not fully backported into RHEL 4 kernel
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 13:53 EST by Tom "spot" Callaway
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 23:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2006-03-30 13:53:13 EST
Description of problem:

While trying to find a way for a third party open source driver to use the
compat_ioctl structure, the vendor discovered:

> However, after looking at the Red Hat 4 kernel sources, it looks like
> the "newish" compat_ioctl() file op hasn't been back-ported to the
> (current?) Red Hat AS/ES/WS 4 kernel, which looks to be 2.6.9-34.

Chip Coldwell responded that:

He's got us here.  I looked at 2.6.9-34.9.  The compat_sys_ioctl system 
call is there, but the .compat_ioctl field is missing from struct 
file_operations (that merits a bugzilla, IMHO).

I think this is just a matter of adding the field to the struct 
file_operations.  However, it's stuck in the middle, so there are kABI 
repercussions.

This is the bugzilla for that issue.
Comment 1 Jason Baron 2006-04-25 10:01:21 EDT
Tom, 

does the register_ioctl32_conversion() solve this issue?

thanks.
Comment 2 Jason Baron 2006-05-03 23:18:31 EDT
should be solved by register_ioctl32_conversion(). closing.

Note You need to log in before you can comment on or make changes to this bug.