This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187424 - bug / feature request: backport bind-tty-special-chars
bug / feature request: backport bind-tty-special-chars
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 15:29 EST by William Yardley
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0680
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 10:57:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bash-bind-stty-chars.patch (2.16 KB, patch)
2007-05-18 05:00 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description William Yardley 2006-03-30 15:29:00 EST
As noted on the bug-bash list, rebinding a character defined by stty is ignored
by bash v3.0. Bash 3.1 / readline 5.0 (5.1?) makes this a configurable option,
by setting:

set bind-tty-special-chars off

http://lists.gnu.org/archive/html/bug-bash/2005-08/msg00003.html
See also RH bug # 139384

(I have a couple posts about this as well, but they're not showing up in the
archive as of this moment).

I've tested, and this works with bash 3.1.x / readline 5.0 in FC5.

As my organization starts deploying RHEL 4 (vs 3), this is going to be a huge
annoyance. Is there any chance of backporting this feature, assuming the major
revision is unlikely to change within RHEL 4? If it matters, the company I work
for has a support contract.
Comment 3 Tim Waugh 2007-05-18 05:00:00 EDT
Created attachment 154983 [details]
bash-bind-stty-chars.patch

This small patch seems to be the extent of it.
Comment 10 errata-xmlrpc 2007-11-15 10:57:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0680.html

Note You need to log in before you can comment on or make changes to this bug.