Bug 1874373 - [v2v][ui] VM import RHV to CNV: RHV URL pass validation though it is missing 'https://'
Summary: [v2v][ui] VM import RHV to CNV: RHV URL pass validation though it is missing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Tomas Jelinek
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On: 1850562
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-01 08:19 UTC by Maayan Hadasi
Modified: 2020-11-16 13:23 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1850562
Environment:
Last Closed: 2020-11-05 12:46:54 UTC
Target Upstream Version:
istein: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6551 0 None closed [release-4.5.z] Bug 1874373: RHV URL validation is missing https:// 2020-11-16 13:06:41 UTC
Red Hat Product Errata RHBA-2020:4325 0 None None None 2020-11-05 12:47:18 UTC

Comment 1 Maayan Hadasi 2020-09-01 08:20:06 UTC
Please consider to backport the bug fix to 4.5.z because the URL correct validation is important, and users can easily get wrong, and have a bad user experience (I had no chance to know that the API URL must include "https://" if I didn't have an example recorded)

Comment 2 Filip Krepinsky 2020-09-08 13:51:52 UTC
depends on https://bugzilla.redhat.com/show_bug.cgi?id=1850562 to be marked as verified to move this one forward

Comment 5 Ilanit Stein 2020-10-30 11:44:11 UTC
Tested on OCP-4.5.16/CNV-2.4

Not adding https:// to the RHV URL - connection successful & VMs are listed.

There is no warning on that https:// is missing.

@Filip is this the expected behavior, or maybe a later OCP version should be tested here?

Comment 6 Ilanit Stein 2020-10-30 15:27:16 UTC
Verified on latest 4.5.z, from Oct 30 2020.

https:// appear inside the URL bar, even before typing the URL.
If I type URL with no https:// I get a red warning right below this field.
The VMs are listed though, even if the URL does not start with https://

Comment 8 errata-xmlrpc 2020-11-05 12:46:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4325

Comment 9 Ilanit Stein 2020-11-16 13:23:00 UTC
On OCP-4.5.19/CNV-2.4.3

In case RHV URL doesn't start with https:// the "Check and save" button is not enabled, and there is an error:
URL has to start with "https://"


Note You need to log in before you can comment on or make changes to this bug.