Bug 1874394 - Unformatted and LDL DASD disks are not formatted with dasdfmt during text installation
Summary: Unformatted and LDL DASD disks are not formatted with dasdfmt during text ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Vendula Poncova
QA Contact: Release Test Team
Alexandra Nikandrova
URL:
Whiteboard:
Depends On:
Blocks: 1812825
TreeView+ depends on / blocked
 
Reported: 2020-09-01 09:24 UTC by Jan Stodola
Modified: 2021-05-18 15:47 UTC (History)
6 users (show)

Fixed In Version: anaconda-33.16.4.1-1
Doc Type: Bug Fix
Doc Text:
.Anaconda now shows a dialog for `ldl` or unformatted DASD disks in text mode Previously, during an installation in text mode, Anaconda failed to show a dialog for Linux disk layout (`ldl`) or unformatted Direct-Access Storage Device (DASD) disks. As a result, users were unable to utilize those disks for the installation. With this update, in text mode Anaconda recognizes `ldl` and unformatted DASD disks and shows a dialog where users can format them properly for the future utilization for the installation.
Clone Of:
Environment:
Last Closed: 2021-05-18 15:47:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Stodola 2020-09-01 09:24:45 UTC
Description of problem:
Anaconda doesn't ask to format unformatted and LDL DASD disks when running in text mode.
Anaconda should format them with CDL, since that's the only supported format for DASD disks in the installer.

Version-Release number of selected component (if applicable):
anaconda-33.16.3.21-1.el8

How reproducible:
Always

Steps to Reproduce:
1a. Unformat DASD: # dasdfmt -y -b 4096 -d cdl /dev/$DASD & pid=$!; sleep 2; kill $pid
1b. Format DASD with LDL: # dasdfmt -y -b 4096 -d ldl /dev/$DASD
2. Start text-mode installation use the prepared DASD on the kernel command line (rd.dasd=$device_number)
3. Select the DASD disk in the "Installation Destination" spoke
4. Continue with the defaults

Actual results:

Anaconda only prints:
"The LDL DASD disk /dev/dasda (0.0.3227) cannot be used for the installation. Please format it."
But do not provide a user friendly way to format the device.

Expected results:

Like in RHEL-8.2 after selecting disk devices, anaconda provides a way to format the disks:
============
The following unformatted or LDL DASDs have been detected on your system. You
can choose to format them now with dasdfmt or cancel to leave them unformatted.
Unformatted DASDs cannot be used during installation.

/dev/dasda (0.0.3227)

Warning: All storage changes made using the installer will be lost when you
choose to format.

Proceed to run dasdfmt?
=============

Comment 21 errata-xmlrpc 2021-05-18 15:47:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (anaconda bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1844


Note You need to log in before you can comment on or make changes to this bug.