Bug 187440 - Opens terminal always in $HOME
Opens terminal always in $HOME
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus-open-terminal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 17:06 EST by Gérard Milmeister
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 14:46:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2006-03-30 17:06:00 EST
The gnome terminal opens, but always in $HOME, and
not the directory, where the action has been
invoked.
Comment 1 Paul W. Frields 2006-03-30 17:27:28 EST
I can't duplicate your problem here.  On all my FC5 systems, the terminal opens
in $HOME only when opened from a desktop right-click or on the user's home
folder.  If I right-click any other folder and choose "Open in Terminal," the
resulting terminal is started with $PWD in that folder.  Please reopen with some
relevant debugging and/or the steps you followed if you can find someone else
who can duplicate this behavior.
Comment 2 Gérard Milmeister 2006-03-30 18:09:59 EST
The problem only appears, if there is already a gnome-terminal open,
otherwise "Open In Terminal" works as expected (for the first terminal).
In "Preferred Applications" I select "GNOME Terminal" which has
a config for "Command:" such that "gnome-terminal --working-directory=%f".
If I change to "Custom" and remove "--working-directory=%f",
nautilus-open-terminal works as expected.
Maybe something other breaks, I don't know.
Comment 3 Raoul 2006-04-13 03:33:11 EDT
I was going to file the same bug, but then I saw Gérard Milmeister's comment.
Removing the "--working-directory=%f" part of the action solves the problem.

In fluxbox, where there is no prefered applications, when using nautilus as file
manager, the open-in-terminal extension works always as expected.
Comment 4 Red Hat Bugzilla 2007-02-05 14:27:05 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 Paul W. Frields 2007-11-14 14:46:06 EST
Current nautilus-open-terminal releases have not used the '--working-directory'
hack for some time, since the product now uses the nautilus URI for opening
folders.  There is no clean way to override old user customizations, however. 
As you have discovered, users can always revert their personal settings and the
extension behaves as expected.

Note You need to log in before you can comment on or make changes to this bug.