Bug 187444 - msp.m4 always overrides confDELIVERY_MODE
msp.m4 always overrides confDELIVERY_MODE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 17:22 EST by James Ralston
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 18:51:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the bug with cf/feature/msp.m4. (502 bytes, patch)
2006-03-30 17:22 EST, James Ralston
no flags Details | Diff

  None (edit)
Description James Ralston 2006-03-30 17:22:14 EST
In all 8.12 and 8.13 versions of sendmail, cf/feature/msp.m4 unconditionally
sets confDELIVERY_MODE to interactive, thereby overriding any attempt to set
confDELIVERY_MODE in submit.mc.

The attached (simple, one-line) patch corrects this issue.

(I've filed this bug against FC5, but this applies to all FC and RHEL releases
that contain sendmail 8.12 or sendmail 8.13.)

Additionally, I've submitted a bug report (plus this patch) upstream to
sendmail-bugs-2006.
Comment 1 James Ralston 2006-03-30 17:22:14 EST
Created attachment 127080 [details]
Patch to fix the bug with cf/feature/msp.m4.
Comment 2 James Ralston 2006-03-30 18:51:29 EST
Bah, my bad--this patch won't work, because msp.m4 can't conditionally set
confDELIVERY_MODE, because confDELIVERY_MODE will always be set to something
(either what was specified in submit.mc, or the default of "background") by the
time the macros in msp.m4 are evaluated.

The *only* way to override the confDELIVERY_MODE in submit.mc is to ensure that
it is defined after FEATURE(`msp'):

FEATURE(`msp')dnl
define(`confDELIVERY_MODE', `defer')

This works.

Note You need to log in before you can comment on or make changes to this bug.