Bug 1874446 - mariadb is improperly configured after update
Summary: mariadb is improperly configured after update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: rawhide
Hardware: x86_64
OS: All
unspecified
low
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-01 11:38 UTC by David Hill
Modified: 2020-10-01 00:15 UTC (History)
8 users (show)

Fixed In Version: mariadb-10.4.14-2.fc32 mariadb-10.4.14-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-05 18:32:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description David Hill 2020-09-01 11:38:32 UTC
1. Please describe the problem:
/etc/my.cnf.d/mariadb-server.cnf contains the following:

[mysqld]
datadir=@MYSQL_DATADIR@
socket=@MYSQL_UNIX_ADDR@
log-error=@LOG_LOCATION@
pid-file=@PID_FILE_DIR@/@DAEMON_NO_PREFIX@.pid

which prevents mariadb from starting with the following error message:
Aug 30 17:35:22 zappa mysql-prepare-db-dir[1656168]: Database MariaDB is not initialized, but the directory @MYSQL_DATADIR@ is not empty, so initialization cannot be done.
Aug 30 17:35:22 zappa mysql-prepare-db-dir[1656168]: Make sure the @MYSQL_DATADIR@ is empty before running mysql-prepare-db-dir.




2. Specify used package versions
# dnf list installed | grep -i -e maria -e mysql -e galera



3. Does a systemd journal say anything about the issue?
# journalctl -xe -u mariadb -u mysqld



4. Please check and attach the MariaDB or MySQL server log?  ("/var/log/mariadb/mariadb.log" or "/var/log/mysql/mysqld.log")



5. Please check and paste your configuration here; remove sensitive information.
# /usr/libexec/mysqld --print-defaults



5. Can you reproduce this issue? If so, please provide the steps to reproduce the issue below:

Comment 1 Michal Schorm 2020-09-02 15:54:35 UTC
Duplicate of BZ: #1873999

Comment 2 Fedora Update System 2020-09-03 19:52:10 UTC
FEDORA-2020-47f48474ae has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-47f48474ae

Comment 3 Fedora Update System 2020-09-03 19:52:14 UTC
FEDORA-2020-b6ef280648 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b6ef280648

Comment 4 Fedora Update System 2020-09-04 02:13:53 UTC
FEDORA-2020-9c0d1f10a5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9c0d1f10a5

Comment 5 Fedora Update System 2020-09-04 15:28:11 UTC
FEDORA-2020-9c0d1f10a5 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-9c0d1f10a5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9c0d1f10a5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-09-04 19:16:37 UTC
FEDORA-2020-b6ef280648 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b6ef280648`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b6ef280648

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-09-05 18:32:26 UTC
FEDORA-2020-9c0d1f10a5 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-10-01 00:15:09 UTC
FEDORA-2020-b6ef280648 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.