Bug 1874529 - Configuring custom certificate for default console route
Summary: Configuring custom certificate for default console route
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1874533 (view as bug list)
Depends On: 1870514
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-01 14:43 UTC by OpenShift BugZilla Robot
Modified: 2020-09-14 14:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 14:54:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 465 None closed [release-4.5] Bug 1874529: Configuring custom certificate for default console route 2020-09-20 06:32:22 UTC
Red Hat Product Errata RHBA-2020:3618 None None None 2020-09-14 14:54:48 UTC

Comment 1 Jakub Hadvig 2020-09-03 07:42:17 UTC
*** Bug 1874533 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2020-09-09 08:51:47 UTC
1. Patch console.operator/cluster with the default console route
$ oc patch consoles.operator.openshift.io cluster --patch '{"spec":{"route":{"hostname”:”<console_default_route>“}}}’ --type=merge
In console-operator logs we can see: 
E0903 05:38:53.700428       1 status.go:78] CustomRouteSyncDegraded InvalidCustomRouteConfig custom route hostname is duplicate of the default route hostname
E0903 05:38:53.700831       1 controller.go:395] console-route-sync--work-queue-key failed with : custom route hostname is duplicate of the default route hostname

2. Do not patch console.operator/cluster with the default console route, only add custom secret
$ oc create secret tls console-serving-cert --cert=./apps.crt --key=./apps.key -n openshift-config
$ oc patch consoles.operator.openshift.io cluster --patch '{"spec":{"route":{"secret":{"name":"console-serving-cert"}}}}' --type=merge

I didn’t see new console pods are created, only the serving certificate is changed to the customized one(viewing certificate info via browser) 

Verified on 4.5.0-0.nightly-2020-09-08-123650

Comment 6 errata-xmlrpc 2020-09-14 14:54:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3618


Note You need to log in before you can comment on or make changes to this bug.