Bug 1874530
| Summary: | Running openshift_node_group.yml to scaleup a node fails with "The error was: 'openshift_is_atomic' is undefined" | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Joel Rosental R. <jrosenta> |
| Component: | Installer | Assignee: | Russell Teague <rteague> |
| Installer sub component: | openshift-ansible | QA Contact: | Gaoyun Pei <gpei> |
| Status: | CLOSED ERRATA | Docs Contact: | |
| Severity: | high | ||
| Priority: | high | ||
| Version: | 3.11.0 | ||
| Target Milestone: | --- | ||
| Target Release: | 3.11.z | ||
| Hardware: | Unspecified | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
Cause: The first master was not getting the openshift_is_atomic var set during playbook initialization.
Consequence: When a later playbook task used the missing fact to set the client binary fact it would fail on undefined.
Fix: Changed the fact setting to include all masters instead of just new masters during scaleup.
Result: Facts are set as expected and playbook completes.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2020-09-16 07:46:50 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Joel Rosental R.
2020-09-01 14:44:32 UTC
Masters are not having facts set during initialization and therefore are failing on the 'openshift_is_atomic' var when attempting to set the 'openshift_client_binary' var. Possible fix will be submitted shortly. Could reproduce this issue with openshift-ansible-3.11.248-1.git.0.fd212c7.el7.noarch.rpm
Add new_nodes/new_masters children group in inventory file.
[OSEv3:children]
masters
nodes
etcd
new_nodes
new_masters
[new_masters]
ec2-54-164-170-200.compute-1.amazonaws.com
[new_nodes]
ec2-54-164-170-200.compute-1.amazonaws.com openshift_node_group_name='node-config-master-crio'
Run playbooks/openshift-master/openshift_node_group.yml playbook, it failed as below:
TASK [set_fact] ****************************************************************
fatal: [ec2-54-152-77-223.compute-1.amazonaws.com]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: 'openshift_is_atomic' is undefined\n\nThe error appears to have been in '/home/slave3/workspace/Run-Ansible-Playbooks-Nextge/private-openshift-ansible/playbooks/init/basic_facts.yml': line 102, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n - set_fact:\n ^ here\n"}
Tried again with openshift-ansible-3.11.284-1.git.0.6025b17.el7.noarch.rpm, passed.
PLAY [Initialize special first-master variables] *******************************
TASK [Gathering Facts] *********************************************************
ok: [ec2-54-152-77-223.compute-1.amazonaws.com]
TASK [set_fact] ****************************************************************
skipping: [ec2-54-152-77-223.compute-1.amazonaws.com] => {"changed": false, "skip_reason": "Conditional result was False"}
TASK [set_fact] ****************************************************************
ok: [ec2-54-152-77-223.compute-1.amazonaws.com] => {"ansible_facts": {"first_master_client_binary": "oc", "l_osm_default_node_selector": "node-role.kubernetes.io/compute=true", "openshift_client_binary": "oc"}, "changed": false}
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (OpenShift Container Platform 3.11.286 bug fix and enhancement update), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2020:3695 |