Bug 1874582 - Azure UPI: Both Internal and External load balancers for kube-apiserver should use /readyz
Summary: Azure UPI: Both Internal and External load balancers for kube-apiserver shoul...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.z
Assignee: Etienne Simard
QA Contact: Mike Gahagan
URL:
Whiteboard:
: 1872822 (view as bug list)
Depends On: 1836016
Blocks: 1872887 1873280
TreeView+ depends on / blocked
 
Reported: 2020-09-01 16:53 UTC by OpenShift BugZilla Robot
Modified: 2020-12-04 18:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4123 0 None closed [release-4.5] Bug 1874582: use https for lb probes in Azure UPI 2020-11-06 20:08:49 UTC
Red Hat Product Errata RHBA-2020:3719 0 None None None 2020-09-21 17:42:21 UTC

Comment 3 Mike Gahagan 2020-09-17 15:29:11 UTC
Confirmed a UPI installation of 4.5 is using TCP for the health checks on both the internal and external load balancers with the /readyz endpoint with 4.5.0-0.nightly-2020-09-16-180742

Comment 5 errata-xmlrpc 2020-09-21 17:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719

Comment 6 Scott Dodson 2020-09-29 15:47:53 UTC
*** Bug 1872822 has been marked as a duplicate of this bug. ***

Comment 7 Scott Dodson 2020-12-04 18:25:08 UTC
*** Bug 1872822 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.