Bug 18746 - Voodoo DRI driver does not compile in kernel
Voodoo DRI driver does not compile in kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 17:30 EDT by Alex Malmyguine
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 09:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Malmyguine 2000-10-09 17:30:16 EDT
Attemt to compile Voodoo Banshee/Vodoo3 DRI in kernel unseccessful. Though 
it compiles as module. Steps to reproduce:

1. make menuconfig -> Character devices -> DRM support [*] -> Voodoo 
Banshee/Voodoo3 support [*]

2. make bzImage -> error message when compiling tdfx_drv.c, line 132
Comment 1 Arjan van de Ven 2000-10-10 02:39:26 EDT
In 2.2.16, you cannot compile the drm drivers into the kernel. They have to be
modules, due to some not-yet present 2.4 mechanisms (__setup is one of them).
These mechanisms are already added to the 2.2.18pre kernel-series to provide
better forward-compatibility.

If needed, I can supply a patch to add them to the 2.2.16 Red Hat kernel as
well.
Comment 2 Alex Malmyguine 2000-10-10 09:14:12 EDT
About the patch - I do not think it's vitally important. Thanks anyway.
Comment 3 Mike A. Harris 2001-08-09 14:58:33 EDT
THis isn't a bug, it is just as Arjan said.  Not a supported
thing to do. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.