Bug 1874618 - there is no unit test CI job for the cluster-api-provider-baremetal repository
Summary: there is no unit test CI job for the cluster-api-provider-baremetal repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Doug Hellmann
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-01 18:30 UTC by Doug Hellmann
Modified: 2020-10-27 16:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:36:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-baremetal pull 107 0 None closed Bug 1874618: add a make target to run only the unit tests 2020-10-07 15:01:23 UTC
Github openshift cluster-api-provider-baremetal pull 108 0 None closed Bug 1874618: add hack scripts to install dependencies for unit tests 2020-10-07 15:01:14 UTC
Github openshift cluster-api-provider-baremetal pull 111 0 None closed Bug 1874618: fix unit tests so we can add a CI job 2020-10-07 15:01:14 UTC
Github openshift release pull 11458 0 None closed Bug 1874618: cluster-api-provider-baremetal: add unit test job 2020-10-07 15:01:23 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:37:10 UTC

Description Doug Hellmann 2020-09-01 18:30:26 UTC
Description of problem:

We have never defined a unit test job for the CAPBM repository, we've always relied just on e2e-metal-ipi to test the component.

Version-Release number of selected component (if applicable):

4.6

How reproducible:

Always

Steps to Reproduce:
1. Submit a PR to cluster-api-provider-baremeta

Actual results:

Observe lint, fmt, etc. tests but no unit tests.

Expected results:

A unit test job.

Additional info:

Comment 1 Bob Fournier 2020-09-09 00:33:44 UTC
This should probably be marked for Squad:Installer, not Squad:HWManagement.

Comment 6 errata-xmlrpc 2020-10-27 16:36:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.