Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionCharles Rose (Dell)
2020-09-01 21:15:07 UTC
Description of problem:
On a Dell PowerEdge R740, When the USB NIC redfish interface on iDRAC is enabled, redfish-finder fails with the error shown below.
Version-Release number of selected component (if applicable):
redfish-finder-0.3-4.el8.noarch
How reproducible:
Always when "Host IP Assignment Type" in dmi type 42 is DHCP.
Steps to Reproduce:
1. Install redfish-finder
2. Start redfish-finder service
3. systemd unit start fails
Actual results:
redfish-finder: Getting dmidecode info
redfish-finder: Unexpected error while parsing HostConfig!
redfish-finder: Building NetworkManager connection info
redfish-finder: Obtaining OS config info
redfish-finder: Converting SMBIOS Host Config to NetworkManager Connection info
Traceback (most recent call last):
File "/usr/bin/redfish-finder", line 535, in <module>
main()
File "/usr/bin/redfish-finder", line 523, in main
if smbios_info.hostconfig.generate_nm_config(smbios_info.device, conn) == False:
File "/usr/bin/redfish-finder", line 174, in generate_nm_config
for i in range(len(self.assigntype)):
AttributeError: 'HostConfig' object has no attribute 'assigntype'
Expected results:
redfish-finder starts without error and pinging 'redfish-localhost' should succeed.
Additional info:
Fix here - https://github.com/nhorman/redfish-finder/commit/581327fd45351dd53c06a26517bb7f92e19d8f31
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (redfish-finder bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2021:1954
Description of problem: On a Dell PowerEdge R740, When the USB NIC redfish interface on iDRAC is enabled, redfish-finder fails with the error shown below. Version-Release number of selected component (if applicable): redfish-finder-0.3-4.el8.noarch How reproducible: Always when "Host IP Assignment Type" in dmi type 42 is DHCP. Steps to Reproduce: 1. Install redfish-finder 2. Start redfish-finder service 3. systemd unit start fails Actual results: redfish-finder: Getting dmidecode info redfish-finder: Unexpected error while parsing HostConfig! redfish-finder: Building NetworkManager connection info redfish-finder: Obtaining OS config info redfish-finder: Converting SMBIOS Host Config to NetworkManager Connection info Traceback (most recent call last): File "/usr/bin/redfish-finder", line 535, in <module> main() File "/usr/bin/redfish-finder", line 523, in main if smbios_info.hostconfig.generate_nm_config(smbios_info.device, conn) == False: File "/usr/bin/redfish-finder", line 174, in generate_nm_config for i in range(len(self.assigntype)): AttributeError: 'HostConfig' object has no attribute 'assigntype' Expected results: redfish-finder starts without error and pinging 'redfish-localhost' should succeed. Additional info: Fix here - https://github.com/nhorman/redfish-finder/commit/581327fd45351dd53c06a26517bb7f92e19d8f31