Bug 18747 - Case-sensitive sorting broken
Summary: Case-sensitive sorting broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-09 21:31 UTC by Alex Malmyguine
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 21:31:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Malmyguine 2000-10-09 21:31:53 UTC
mc does not sort case sensitive

Comment 1 Alan Cox 2000-10-09 23:41:16 UTC
Sorting is determined by national language settings. For English (UK and US)
that is AaBbCcDd etc not ABCD-Zabcd-z. So if its sorting AaBbCc etc then the
behaviour is correct.

If you prefer the old (wrong) behaviour set LC_COLLATE appropriately


Comment 2 Alex Malmyguine 2000-10-10 13:11:19 UTC
This is exactly what is called 'case insensitive'. If this is intended behavior 
than the check box is confusing and has to be renamed or removed.
No matter what was the reason for change, following had to be taken into 
consideration: mc is a tool for those who are not so computer literally, in 
simple words, for users and this category of people really has problems 
adjusting to the changed behavior.
What I suugest is making old sorting order default and new an option until it 
becomes common. Remember that not everybody will immediatelly move to the 
latest version and there still will be thousands users used to it. In that 
world is't enough to begin your file name with a capital letter to have it on 
top of the list, which is quite convenient.


Note You need to log in before you can comment on or make changes to this bug.