Bug 187471 - disk partitioning tool labels / as /1 without reason
disk partitioning tool labels / as /1 without reason
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 02:34 EST by feily
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 14:48:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (31.10 KB, text/plain)
2006-06-14 06:46 EDT, feily
no flags Details
install.log.syslog (4.23 KB, application/octet-stream)
2006-06-14 06:47 EDT, feily
no flags Details

  None (edit)
Description feily 2006-03-31 02:34:03 EST
Description of problem:
If there is already a / partition with label / and I chose to take this
partition as / again and select to format with ext3 it is relabled to /1.

Version-Release number of selected component (if applicable):
11.0.5-1

How reproducible:
always

Steps to Reproduce:
1. install fc5 on a disk where there is already a / partition with label /
2. take this partition as / again
3. select format as ext3
  
Actual results:
/ partition has label /1

Expected results:
should have /

Additional info:
Comment 1 David Cantrell 2006-03-31 10:25:50 EST
Are there any other partitions on any other disks in the system with a / label?
Comment 2 feily 2006-04-01 02:12:27 EST
No.
First disk with /, swap, a ntfs partition and some free space.
Second disk with /home.
All primary partitions.
Selected to format / and leave /home untouched.
Comment 3 David Cantrell 2006-05-22 12:53:16 EDT
If you have the /root/install.log and /root/install.log.syslog files on your
system, please attach those.

This does not sound like a bug to me.  Anaconda avoids label collisions on
filesystems, so even if you want to use a partition as the / filesystem and you
tell it to reformat, anaconda still checks for other labels on the system.  If
you have any other distributions installed, other hard disks with labels,
etc...anaconda will rename its filesystems to avoid label collisions.  The label
tries to match the mountpoint, but it may not if you already have a label by
that name.  In the end, it really doesn't matter as the label is entirely
arbitrary anyway.
Comment 4 feily 2006-06-14 06:46:49 EDT
Created attachment 130817 [details]
install.log
Comment 5 feily 2006-06-14 06:47:32 EDT
Created attachment 130818 [details]
install.log.syslog
Comment 6 feily 2006-06-14 07:02:46 EDT
The label may not match the mountpoint if you already have a label by that name,
and the partition with that label is not the new partition.
Comment 7 David Cantrell 2007-03-05 14:48:44 EST
Yeah, this is expected behaviour because we need to avoid filesystem label
collisions.  If your Fedora root partition is labeled as /1, then there *is*
another partition that we can see that already has a / label.  Since we cannot
relabel other partitions, we adjust our labels accordingly.

Note You need to log in before you can comment on or make changes to this bug.