Bug 18748 - Fatal server error: could not open default font 'fixed'
Fatal server error: could not open default font 'fixed'
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 18:13 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 16:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-09 18:13:26 EDT
Hi,

I can no longer start X. When I type 'startx' I receive the following 
error:

"failed to set default font 
path '/usr/X11R6/lib/X11/fonts/TrueType,unix/:7100'
Fatal server error:
could not open default font 'fixed'"

[the full error message from "startx 2> error.txt" is below]

Originally, I had a three-day old RH 7.0 nicely running. I had just 
upgraded from RH 6.2 and successfully installed a new set of TrueType 
fonts. My problems started after a second attempt of adding yet another 
set of TrueType fonts. I cannot recall that I have by accident deleted any 
fonts named 'fixed'.

But first, I DO NOT run an smp-machine, as indicated in the error output. 
I have a single-CPU P2-300, 192 MB RAM, and 2+10 GB HDs, etc.

Second, I thought I was running XFree86 4.0.1, and not 3.3.6 as indicated 
in the output ?!

After hours of unluck, I submit this to you for assistance.

Thank you very much for your kind help!

Rudy Mansgaten
===================start-of-error-message========================
XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF] 
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 1):
      s3_savage, NV1, STG2000, RIVA 128, RIVA TNT, RIVA TNT2,
      RIVA ULTRA TNT2, RIVA VANTA, RIVA ULTRA VANTA, RIVA INTEGRATED,
      GeForce 256, GeForce DDR, Quadro, ET4000, ET4000W32, ET4000W32i,
      ET4000W32i_rev_b, ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a,
      ET4000W32p_rev_b, ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100,
      et3000, pvga1, wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33,
      gvga, r128, ati, sis86c201, sis86c202, sis86c205, sis86c215,
      sis86c225, sis5597, sis5598, sis6326, sis530, sis620, sis300, sis630,
      sis540, tvga8200lx, tvga8800cs, tvga8900b, tvga8900c, tvga8900cl,
      tvga8900d, tvga9000, tvga9000i, tvga9100b, tvga9200cxr, tgui9400cxi,
      tgui9420, tgui9420dgi, tgui9430dgi, tgui9440agi, cyber9320, tgui9660,
      tgui9680, tgui9682, tgui9685, cyber9382, cyber9385, cyber9388,
      cyber9397, cyber9520, cyber9525, 3dimage975, 3dimage985, 
cyber9397dvd,
      blade3d, cyberblade, clgd5420, clgd5422, clgd5424, clgd5426, 
clgd5428,
      clgd5429, clgd5430, clgd5434, clgd5436, clgd5446, clgd5480, clgd5462,
      clgd5464, clgd5465, clgd6205, clgd6215, clgd6225, clgd6235, clgd7541,
      clgd7542, clgd7543, clgd7548, clgd7555, clgd7556, ncr77c22, 
ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP, mgag200,
      mgag100, mgag400, oti067, oti077, oti087, oti037c, al2101, ali2228,
      ali2301, ali2302, ali2308, ali2401, cl6410, cl6412, cl6420, cl6440,
      video7, ark1000vl, ark1000pv, ark2000pv, ark2000mt, mx, realtek,
      s3_virge, AP6422, AT24, AT3D, s3_svga, NM2070, NM2090, NM2093, 
NM2097,
      NM2160, NM2200, ct65520, ct65525, ct65530, ct65535, ct65540, ct65545,
      ct65546, ct65548, ct65550, ct65554, ct65555, ct68554, ct69000,
      ct64200, ct64300, mediagx, V1000, V2100, V2200, p9100, spc8110, i740,
      i740_pci, Voodoo Banshee, Voodoo3, i810, i810-dc100, i810e, smi,
      generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "se"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 5
(**) Mouse: zaxismapping: (-)4 (+)5
(**) SVGA: Graphics device ID: "Matrox|MGA G400 AGP"
(**) SVGA: Monitor ID: "CustomConfiguration"
(--) SVGA: Mode "1024x768" needs hsync freq of 80.21 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 70.24 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 89.62 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 70.88 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 76.01 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 74.59 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 78.86 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 81.13 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 91.15 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 75.00 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 87.50 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 93.75 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/TrueType,unix/:7100"
(--) SVGA: PCI: Matrox MGA G400 AGP rev 3, Memory @ 0xf4000000, 
0xfe000000, MMIO @ 0xfedf8000
(--) SVGA: Linear framebuffer at 0xF4000000
(--) SVGA: MMIO registers at 0xFEDF8000
(--) SVGA: Video BIOS info block at 0x000c7a80
(--) SVGA: Video BIOS info block not detected!
(--) SVGA: detected an SGRAM card
(--) SVGA: chipset:  mgag400
(**) SVGA: videoram: 16384k
(**) SVGA: Option "dac_8_bit"
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 300.000 MHz
(**) SVGA: Mode "640x480": mode clock =  36.000
(**) SVGA: Mode "800x600": mode clock =  60.750
(**) SVGA: Mode "1024x768": mode clock =  85.000
(**) SVGA: Mode "1152x864": mode clock =  92.000
(**) SVGA: Mode "1280x1024": mode clock = 110.000
(--) SVGA: Virtual resolution set to 1280x1024
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: Using hardware cursor
(--) SVGA: PLL reference freq: 27.050 MHz
(--) SVGA: Read OPTION 0x50044120
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: 8x8 color expand pattern fill
(--) SVGA: XAA: CPU to screen color expansion (TE/NonTE imagetext, 
TE/NonTE polytext)
(--) SVGA: XAA: Using 10 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and stipples
(--) SVGA: XAA: General lines and segments
(--) SVGA: XAA: Dashed lines and segments
failed to set default font 
path '/usr/X11R6/lib/X11/fonts/TrueType,unix/:7100'
Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

X connection to :0.0 broken (explicit kill or server shutdown).
=====================end-of-error-message========================
Comment 1 Spider 2000-10-10 01:37:21 EDT
do a 
ls -l /etc/X11/X 
You'll most likely note that X points at /usr/bin/X11/XF86_SVGA instead of
/usr/bin/X11/XFree86 
common behaviour with upgrades between X versions
als check ls -l /usr/bin/X11/X  to see what that points to
Comment 2 Need Real Name 2000-10-11 14:29:08 EDT
Hi Spider,

Thanks for the input! You were correct in that X points 
at /usr/bin/X11/XF86_SVGA instead of /usr/bin/X11/XFree86.

Also, /usr/bin/X11/X points to Xwrapper, as you probably already knew.

However, I have been reading as much documentation as I have available (both on-
line and books; however, most are pre-4.0.1 oriented), and I am still at a loss 
as to what to do next... I tried Xconfigurator, but that only autodetects the 
pointer to XF86_SVGA and does not let me re-direct X to XFree86. I have not yet 
tried xf86config, however. I have checked a lot of files (e.g. XF86Config 
and .xinitrc) but cannot find any obvious reference to /usr/bin/X11/XF86_SVGA 
which could be changed to /usr/bin/X11/XFree86.

Please, can you direct me to the appropriate file/program where to make my 
changes.


Thanks in advance,

Rudy Mansgaten

[#18748]
Comment 3 Spider 2000-10-12 19:38:05 EDT
Actually, the documentation you are after are in the release of XFree86 4.0
manpages
man XFree86 
man XF86Config
man X
man Xserver
should be the most essential parts.

but basically, you have to change the mentioned symlink so it points at XFree86
(4.0) 
then you have to upgrade/change your config file /ets/X11/XF86Config so it works
with XFree86 ver. 4

there are several ways, one is toi run /usr/X11/bin/XFree86 -configure, others
is to use a configuratoin tool. you could also contact me privately and I can
supply you with a minimal start for a config file.

--
//Spider -- 
if its real it is real it is really surreal...
Comment 4 Carlo Wood 2000-11-01 07:01:49 EST
I had this problem too just now.
The reason was that I had added 'umask 027' to /root/.bashrc
Having an umask of 027 as root results in the following:
at boot the /etc/rc.d/init.d/xfs script generates the fonts.dir file
(and perhaps one or two other files?) with mode rw-r-----
Then it start xfs as "xfs -droppriv -daemon".  After dropping
priveledges it can't read the generated files anymore and
Aborts (try starting xfs manually as "xfs -droppriv").
No need to say that when xfs doesn't run you get the error
as stated in this bug report.

Hope this helps to fix it,

Carlo Wood
Comment 5 Bill Nottingham 2000-11-04 02:12:43 EST
Yes, the general solution to this error message
is to make sure that the font server is running.

Perhaps the default umask should be changed in the
xfs script to avoid some of the problems mentioned.
Comment 6 Mike A. Harris 2001-03-20 02:34:04 EST
I have changed the default umask in xfs initscript to 133.
This should appear in 4.0.3-2

Note You need to log in before you can comment on or make changes to this bug.