Bug 1874920 - revert "kube-scheduler: dump node infos when scheduling"
Summary: revert "kube-scheduler: dump node infos when scheduling"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Jan Chaloupka
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1874919
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-02 15:05 UTC by Jan Chaloupka
Modified: 2020-10-27 16:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1874919
Environment:
Last Closed: 2020-10-27 16:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 345 0 None closed bug 1874920: Revert "bug 1874919: UPSTREAM: 94423: debugger scheduler plugin" 2020-09-25 13:46:50 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:37:26 UTC

Description Jan Chaloupka 2020-09-02 15:05:48 UTC
+++ This bug was initially created as a clone of Bug #1874919 +++

Upstream PR: https://github.com/kubernetes/kubernetes/pull/94423

To get requested resources inside scheduler's node cache to debug https://bugzilla.redhat.com/show_bug.cgi?id=1870342

Comment 1 Jan Chaloupka 2020-09-10 14:10:31 UTC
Putting UpcomingSprint here just in case the PR does not get merged before EOW

Comment 3 zhou ying 2020-09-21 01:55:36 UTC
checked with payload:4.6.0-0.nightly-2020-09-20-184226 , when scheduling pod , could see the debug info:

I0921 01:53:11.008311       1 debugger.go:65] "Dumping node infos" node="ip-10-0-153-122.us-east-2.compute.internal" requested="[cpu=753m memory=4243Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.009051       1 debugger.go:65] "Dumping node infos" node="ip-10-0-175-218.us-east-2.compute.internal" requested="[cpu=846m memory=4253Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.009378       1 debugger.go:65] "Dumping node infos" node="ip-10-0-197-106.us-east-2.compute.internal" requested="[cpu=2074m memory=6429Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.010005       1 debugger.go:65] "Dumping node infos" node="ip-10-0-158-129.us-east-2.compute.internal" requested="[cpu=1971m memory=6119Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.010553       1 debugger.go:65] "Dumping node infos" node="ip-10-0-185-9.us-east-2.compute.internal" requested="[ephemeral-storage=0 cpu=1714m memory=4879Mi pods=0]"
I0921 01:53:11.010581       1 debugger.go:65] "Dumping node infos" node="ip-10-0-208-253.us-east-2.compute.internal" requested="[cpu=404m memory=1520Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.037530       1 scheduler.go:597] "Successfully bound pod to node" pod="openshift-kube-scheduler/test-659977979-jlhwq" node="ip-10-0-208-253.us-east-2.compute.internal" evaluatedNodes=6 feasibleNodes=3

Comment 4 zhou ying 2020-09-21 01:55:51 UTC
checked with payload:4.6.0-0.nightly-2020-09-20-184226 , when scheduling pod , could see the debug info:

I0921 01:53:11.008311       1 debugger.go:65] "Dumping node infos" node="ip-10-0-153-122.us-east-2.compute.internal" requested="[cpu=753m memory=4243Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.009051       1 debugger.go:65] "Dumping node infos" node="ip-10-0-175-218.us-east-2.compute.internal" requested="[cpu=846m memory=4253Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.009378       1 debugger.go:65] "Dumping node infos" node="ip-10-0-197-106.us-east-2.compute.internal" requested="[cpu=2074m memory=6429Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.010005       1 debugger.go:65] "Dumping node infos" node="ip-10-0-158-129.us-east-2.compute.internal" requested="[cpu=1971m memory=6119Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.010553       1 debugger.go:65] "Dumping node infos" node="ip-10-0-185-9.us-east-2.compute.internal" requested="[ephemeral-storage=0 cpu=1714m memory=4879Mi pods=0]"
I0921 01:53:11.010581       1 debugger.go:65] "Dumping node infos" node="ip-10-0-208-253.us-east-2.compute.internal" requested="[cpu=404m memory=1520Mi pods=0 ephemeral-storage=0]"
I0921 01:53:11.037530       1 scheduler.go:597] "Successfully bound pod to node" pod="openshift-kube-scheduler/test-659977979-jlhwq" node="ip-10-0-208-253.us-east-2.compute.internal" evaluatedNodes=6 feasibleNodes=3

Comment 5 zhou ying 2020-09-25 13:51:10 UTC
Confirmed with payload: 4.6.0-0.nightly-2020-09-25-085318, can't see the logs in https://bugzilla.redhat.com/show_bug.cgi?id=1874920#c4 anymore. will move to verified status.

Comment 9 errata-xmlrpc 2020-10-27 16:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.