Bug 187495 - autofs won't mount samba shares
autofs won't mount samba shares
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 07:30 EST by adriano
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 04:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
daemon debug log of autofs (5.08 KB, text/plain)
2006-03-31 13:09 EST, adriano
no flags Details

  None (edit)
Description adriano 2006-03-31 07:30:45 EST
Description of problem: autofs won't mount configured samba shares in
auto.master. I use a map file with the samba resources list.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeffrey Moyer 2006-03-31 09:07:51 EST
Please provide all of the information requested in the "Filing bug reports"
section of the following web page:

    http://people.redhat.com/jmoyer/

Thank you.
Comment 2 adriano 2006-03-31 13:09:28 EST
Created attachment 127142 [details]
daemon debug log of autofs

auto.master content
/mnt/samba	/etc/auto.samba --timeout=60 --debug --verbose
Comment 3 Jeffrey Moyer 2006-03-31 15:38:47 EST
OK, it appears that the auto.smb script is outputing an erroneous entry.  It
should escape the // with a :, but it doesn't.  From your debug trace:

lookup(file): sep5 ->
-fstype=smbfs,uid=500,gid=500,dmask=0750,fmask=0750,username=jamesbond,password=mypassword
//10.170.102.254/d\$

the "//10.170.102.254/d\$" should read "://10.170.102.254/d\$"

Are you using the stock script that ships with autofs version 4.1.4-16.2.2?  I
have tried with the version from CVS, and it works fine.

Could you please attach your auto.smb script?  Thanks.
Comment 4 Radek Bíba 2006-04-01 03:59:20 EST
Please note that smbfs has been removed from FC5, e.g. samba changelog reads:

* Mon Feb 13 2006 Jay Fenlason <fenlason@redhat.com> 3.0.21b-2
- New upstream version.
- Since the rawhide kernel has dropped support for smbfs, remove smbmount
  and smbumount.  Users should use mount.cifs instead.

If your autofs config file contains something like:
stuff -fstype=smbfs,username=asd,password=fgh ://server/stuff
then autofs will not work. Use something like this instead:
stuff -fstype=cifs,username=asd,password=fgh ://server/stuff
Comment 5 adriano 2006-04-03 04:48:44 EDT
I have changed -fstype=smbfs with -fstype=cifs but nothing changed..
Follows auto.samba map file line of my share,
sep5   
-fstype=cifs,uid=500,gid=500,dmask=0750,fmask=0750,username=jamesbond,password=mypassword
 ://10.170.102.254/d\$
Comment 6 adriano 2006-04-03 04:53:02 EDT
OK, there was an error in my auto.samba map file. Now it works, the original
problem was the option -fstype=smbfs. Thanks for all.

Note You need to log in before you can comment on or make changes to this bug.