Bug 187510 - CVE-2006-0996 phpinfo() XSS issue
CVE-2006-0996 phpinfo() XSS issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
impact=low,reported=20060330,source=r...
: Security
Depends On:
Blocks: 175040
  Show dependency treegraph
 
Reported: 2006-03-31 10:18 EST by Josh Bressers
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHSA-2006-0276
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 10:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2006-03-31 10:18:24 EST
phpinfo() XSS issue

An XSS issue has been found in phpinfo().  The CVS commit information
is here:

http://marc.theaimsgroup.com/?l=php-cvs&m=114374620416389&w=2


This issue also affects RHEL3
This issue also affects RHEL2.1
Comment 1 Josh Bressers 2006-04-10 09:50:42 EDT
There is more information here:
http://securityreason.com/achievement_securityalert/34
Comment 4 Red Hat Bugzilla 2006-04-25 10:28:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0276.html
Comment 5 Marc Deslauriers 2006-04-29 13:36:43 EDT
Patch php-4.3.9-CVE-2006-0996.patch is incorrect. There is no TSRMLS_CC in
zend_print_zval_ex().

Note You need to log in before you can comment on or make changes to this bug.