Bug 187516 - gDesklets bail when starting up. (Newbie)
gDesklets bail when starting up. (Newbie)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdesklets (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luya Tshimbalanga
: Reopened
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-03-31 10:50 EST by Brian Durant
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 18:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Durant 2006-03-31 10:50:19 EST
Description of problem:

I couldn't find a component section for this, so I picked what I considered a
similar component. The problem is simply that gDesklets bails when starting up.
I can never actually get gDesklets to start.

Version-Release number of selected component (if applicable):

latest

How reproducible:

everytime

Steps to Reproduce:
1. Choose gDesklets from program --> accessories.
2.
3.
  
Actual results:

gDesklets quits when starting the program.

Expected results:

That it would work?


Additional info:

G5 single (PowerMac 9.1)
Comment 1 Karsten Hopp 2006-04-02 05:01:14 EDT
The gdesklets maintainer needs to request a bugzilla entry for this package and
adjust the component/distribution when this is done. I'll assign it manually to
him for now.
Comment 2 Luya Tshimbalanga 2006-04-02 16:36:36 EDT
Actually gdesklets is in Fedora Extras products list. Could you reproduce the
bug with the terminal (Application --> Accessories --> Terminal) then type
gdeskkets --debug?
Comment 3 Brian Durant 2006-04-03 04:46:50 EDT
$ gdesklets --debug

"You're running gDesklets for the first time.
gDesklets will start a requirements check now...

Checking requirements:
 - sys ... found
 - xml.parsers.expat ... found
 - xml.sax ... found
 - gtk ... found
 - ORBit ... found
Version check failed.

ORBit python bindings (pyorbit) version == 2.0.1 are required.

Please make sure that the required software is installed.
Also try to avoid having multiple versions of a library/binding on your system.
gDesklets won't work if you don't have all necessary dependencies installed
on your system.

THE STARTUP WILL BE CANCELLED NOW!"

As far as I know, nothing I have installed has changed the original pyorbit that
came with FC 5. How do I install this (sudo yum install pyorbit)?
Comment 4 Luya Tshimbalanga 2006-04-03 14:06:25 EDT
Strange that ppc64 required pyorbit 2.0.1 where the spec file actually
mentionned >= 2.0.1 which worked fine on other architecture. Did you use the
ppc32 version to verify if the issue get solved? I will release an update to see
if the problem goes away.
Comment 5 Brian Durant 2006-04-03 15:05:48 EDT
I haven't done anything yet. I'll wait for the update.
Comment 6 Luya Tshimbalanga 2006-04-11 16:25:17 EDT
Further details about gDesklets. I updated the package which will be available
sooner. I found a workaround that consists to start gDesklets from the terminal
once, exit and restart it from the menu. Hope if help. Sorry for the delay.
Comment 7 Luya Tshimbalanga 2006-05-29 13:00:46 EDT
Gdesklets works fine on the system. Until the problem emerged once again, this
bug report is now closed.
Comment 8 Michael Schwendt 2006-05-29 14:02:05 EDT
Please don't close a bug as WORKSFORME when you released an update.
Use CLOSED/NEXTRELEASE or CLOSED/ERRATA

I've had a look at your CVS "fix" and don't understand it. In comment 3,
Brian report debug output about a failed version check. You've not done
anything about that version check. Instead, you've only replaced a minimum
version of a build requirement in the spec file.

The failure is still reproducible here:

$ rpm -q gdesklets
gdesklets-0.35.3-8.fc5
$ rm -rf $HOME/.gdesklets
$ gdesklets --debug
Comment 9 Josep 2006-06-04 19:19:41 EDT
This bug affects i386 architecture as well.
I just installed gdesklets and I ran into the very same problem as Brian
reported ("ORBit python bindings (pyorbit) version == 2.0.1 are required."). The
output of "gdesklets --debug" is the same as in comment #3.

My system is fully updated as of Jun 5, 2006.
Comment 10 Luya Tshimbalanga 2006-06-05 06:20:14 EDT
(In reply to comment #9)
> This bug affects i386 architecture as well.
> I just installed gdesklets and I ran into the very same problem as Brian
> reported ("ORBit python bindings (pyorbit) version == 2.0.1 are required."). The
> output of "gdesklets --debug" is the same as in comment #3.
> 
> My system is fully updated as of Jun 5, 2006.
> 

Current workaround posted from an user:

This works fine on FC5, maybe it'll help on other distros:

Open the file /usr/lib/gdesklets/gdesklets in a text editor (I used vi) and find
the two lines where the dependency is checked:

( ("ORBit",), lambda m : m.__version__ == (2, 0, 1),
_("ORBit python bindings (pyorbit) version == 2.0.1 are required.")


then edit the entries to read:

( ("ORBit",), lambda m : m.__version__ >= (2, 0, 1),
_("ORBit python bindings (pyorbit) version >= 2.0.1 are required.")

I will investigate further about this issue.
Comment 11 Luya Tshimbalanga 2006-08-31 03:49:53 EDT
It has been a while I checked that bug report. I finally look around to find out
it is an upstream bug i.e. it is a problem related to gdesklets itself. While
the workaround is available online, I will prepare an updated version with a
patch. Sorry for the very long delay of response.
Comment 12 Luya Tshimbalanga 2006-08-31 18:41:58 EDT
The package is now updated with added patch against pyorbit requirement found on
upstream package. Check out the package on Extras repository and let me know if
the problem occurs on PPC.

Note You need to log in before you can comment on or make changes to this bug.