Bug 187526 - Click-through explanation of Fedora goals
Click-through explanation of Fedora goals
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 12:11 EST by Ian Pilcher
Modified: 2014-03-16 22:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 15:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2006-03-31 12:11:51 EST
Description of problem:

The fact that Fedora does not support various technologies -- MP3, DVD, Sun
Java, proprietary graphics drivers, etc. comes up with annoying regularity
on the Fedora mailing lists.  Information about why things are the way they
are isn't exactly hard to find, but it seems that a certain number of people
simpley aren't willing to even try.

Obviously, a bigger hammer is needed.  I suggest that a click-through be
added to Anaconda, which explains this.  I think it's worth considering
going further and putting something like "Don't Install This Software..."
in big bold print at the top of said click-through.


Version-Release number of selected component (if applicable):

anaconda-11.1.0.2-1


How reproducible:

100%


Steps to Reproduce:

1.  Subscribe to the Fedora mailing list.
2.  Wait a few days...
  
Actual results:

See the "Fedora's way forward" thread.


Expected results:

"You clicked on the 'I understand' button when you installed Fedora, what
part of no don't you understand?"


Additional info:
Comment 1 Jon Masters 2006-05-15 14:29:40 EDT
I think this would make more sense in gnome-session on a per-user first login
basis with a side wide disable function. Then people can't easily ignore it.

Jon.
Comment 2 Jeremy Katz 2006-05-15 14:53:09 EDT
Having this in the installer doesn't make sense as it doesn't help for cases
where, eg, Fedora is preinstalled on your system
Comment 3 Ian Pilcher 2006-05-15 15:00:46 EDT
A couple of points:

1.  Not everyone uses GNOME.

2.  In my mind, the target audience for this warning is the people who are
    installing Fedora Core.  The earlier they see this message, the better.
    Someone confronted with a pre-configured Fedora desktop is likely to
    complain to their helpdesk, spouse, significant other (whoever set up
    Fedora Core in the first place).  I believe that our objective should be
    to equip that person/organization to respond.

What the heck, put it in both places.  :-)
Comment 4 Mike A. Harris 2006-05-15 19:11:30 EDT
I think this is the wrong approach.  This is a "reactive" approach IMHO
by giving people excuses why thing are not part of the OS, instead of telling
them what they want to know, which is how they can have such support.

We should either leave it as it is now, or we should inform people via
dialog or whatever, _where_ they can get _LEGAL_ software to do what they
want.  Of course we should not point people to any places that have illegal
software, or software of legal questionability.

By pointing people to where they can obtain legal software for mp3 playback,
DVD playback, etc. we would be being proactive about it at least.

However, even though I think this would be the right "proactive" approach,
I don't think it will solve the problem.  There will be people who are
used to various legally questionable software being available in other
distributions, or from random download sites out there, and they will expect
that software to be included in Fedora Core, just like it is included in
some other distributions out there which do not have much regard for
legal concerns.

We can explain /why/ we don't include certain things until we're blue in
the face, but the fact is, people generally do not want to hear it.  They
just want the software they want, period, and from their viewpoint, if
Ubuntu, or whatever other distro ships the software they want, then there
is no reason Fedora should not ship it as well.  These people do not want
to hear us tell them "If Ubuntu were to jump into a live volcano, should
Fedora do that too?"

The problem is that we are faced by certain legal realities, and legal
risks, and have taken a position that protects our distribution and our
company from legal problems resulting from shipping questionable software,
however the unwashed masses out there do not generally care much about
legal mumbo jumbo, legal grey areas, and think if one person/group/company
can do something and get away with it, that it is ok for everyone to do it.

No amount of argument/debate/information/explanation/whatever is going to
change the irrational thought process of the average joe who does not have
any knowledge of law, and generally doesn't care about it either, because
it is so unlikely for it to ever affect them personally.  The law doesn't
go after "Joe", it goes after large corporations, and Joe doesn't grok the
difference, or care.  Joe just wants to do what he wants, regardless of
the law.

IMHO, the best thing we can do at least in the current climate, is to
do what we've done all along, and point people to well written documentation
on the Fedora site.

If this "problem" truly becomes a large enough problem in which boatloads
of Fedora users start flocking to Ubuntu or some other distro that may or
may not ship legally questionable software that users crave, we can always
solve that problem when the time comes.
Comment 5 Jon Masters 2006-05-15 21:34:31 EDT
My previous points elsewhere were to the effect that we need a dialog that
points the user to legal alternatives as ways of providing what they may
consider to be missing. I think this is a serious problem and one that is
(wrongfully) costing Fedora mindshare. I see reaction from many that confirms
this belief.
Comment 6 Karsten Wade 2006-05-17 10:39:00 EDT
Note that the subject is addressed in the release notes.

http://fedora.redhat.com/docs/release-notes/fc5/release-notes-ISO/#id3145731

Which are available in the installer.

Which appear as the default homepage for Firefox on a newly installed system.

If you install FC 5 right now, this is what appears for English:

http://fedora.redhat.com/docs/release-notes/fc5/release-notes-ISO/

The local file /usr/share/doc/HTML/index.html has a side bar navigation that
points at fedorafaq.org and fedoraforum.org.  Either of those Websites has
plenty of answers about MP3, DVD, etc.

Just noting that we have not been entirely negligent in our duties to inform and
help out.
Comment 7 Jon Stanley 2008-05-12 15:48:00 EDT
I'm going to close this bug - we have codeina now.  While not a perfect
solution, it's probably the best we can do.

Note You need to log in before you can comment on or make changes to this bug.