Bug 1875303 - Undiagnosed panic detected in multus pod
Summary: Undiagnosed panic detected in multus pod
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-03 09:27 UTC by Michal Fojtik
Modified: 2020-10-27 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:37:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift network-metrics-daemon pull 26 0 None closed Bug 1875303: Fix panic on delete as tombstone is not handled 2021-02-17 21:58:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:37:43 UTC

Description Michal Fojtik 2020-09-03 09:27:28 UTC
Description of problem:

pods/openshift-multus_network-metrics-daemon-zkzgv_network-metrics-daemon.log.gz:E0903 08:39:30.870154       1 runtime.go:78] Observed a panic: &runtime.TypeAssertionError{_interface:(*runtime._type)(0x1321ec0), concrete:(*runtime._type)(0x13b7ec0), asserted:(*runtime._type)(0x14c8c40), missingMethod:""} (interface conversion: interface {} is cache.DeletedFinalStateUnknown, not *v1.Pod)

Seen in https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-origin-installer-e2e-gcp-upgrade/1301418889644609536

This is effectively failing the promotion job, so setting severity urgent.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Weibin Liang 2020-09-21 14:35:53 UTC
Checked in https://search.ci.openshift.org/?search=pods%2Fopenshift-multus_network-metrics-daemon&maxAge=48h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job, does not see
the any new pods/openshift-multus_network-metrics-daemon panic log.

Comment 5 errata-xmlrpc 2020-10-27 16:37:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.