Bug 187545 - Red characters on blue background during initial install
Summary: Red characters on blue background during initial install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: newt   
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-31 20:34 UTC by Don Dugger
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 15:59:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Don Dugger 2006-03-31 20:34:05 UTC
Description of problem:

During the initial install phase, before the graphical X window is brought up, 
there are questions, specifically those needed for a network install, that 
appear as red characters on a blue background.  For those of us with red-green 
color blindness issues this color scheme is practically unreadable.  The Fedora 
Core 4 installer used white characters on a blue background, much more readable.


Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1. Boot the install DVD with the command `linux askmethod'
2. Ask for an NFS install

  
Actual results:
Observe that all user selectable items (keyboard type, language, network setup 
parameters) appear as red on blue.

Expected results:
White on blue would be much more readable.


Additional info:
I've observed this problem on two different machines, one using a Voodoo 3 video 
card and the other using an Intel 82915G/GV/910GL video chipset, both systems 
connected to the same NEC E1100+ monitor.

PS:  The initial screen where you select the `linux askmethod' shows option key 
help text as red on black, again, those red characters are hard to read.

Comment 1 Miroslav Lichvar 2006-05-29 11:14:40 UTC
The workaround is to use frame buffer, add vga=0x301 to boot arguments and
yellow will be yellow again. Older installers used frame buffer.

The problem is in VGA console, it will display only 8 colors when it is switched
to unicode (512 glyphs font). Of course, in such case it would be good to switch
to an 8 color scheme.

Comment 2 Miroslav Lichvar 2006-06-08 15:59:33 UTC
Fixed in newt-0.52.2-7.


Note You need to log in before you can comment on or make changes to this bug.