Bug 187546 - Non antialiased text
Summary: Non antialiased text
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wine   
(Show other bugs)
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-31 20:36 UTC by Gen Zhang
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: wine-0.9.13-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 19:06:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of winecfg (9.03 KB, image/png)
2006-04-03 21:48 UTC, Gen Zhang
no flags Details
screenshot of firefox (129.88 KB, image/png)
2006-04-03 21:49 UTC, Gen Zhang
no flags Details

Description Gen Zhang 2006-03-31 20:36:31 UTC
Description of problem:
Text is not antialiased. Perhaps a problem with not building with freetype?

Version-Release number of selected component (if applicable):
0.9.10-2.fc5

How reproducible:
Always, easily. Winecfg should have antialiased text, based on experience from
building by hand.

I know that this is probably fair low priority, but it would be nice to see
everything in antialiased goodness. It always amused me that I could get nicer
fonts in my Windows apps in Wine than on Windows proper. :)

Comment 1 Gen Zhang 2006-03-31 21:22:30 UTC
Installing Firefox, it shows that the only fonts it sees are System, Courier and
MS Sans Serif. It is undoubtly a font issue. On the other hand, the first time
wine started it took a very long time to scan through all the fonts on the
system, so it's not entirely that it can't find any fonts.

Comment 2 Andreas Bierfert 2006-04-02 08:51:40 UTC
This bug will be fixed in the near future... Thanks so for reporting it :)

Comment 3 Gen Zhang 2006-04-02 12:06:20 UTC
I'm not sure if I should be asking this here, but how are you currently building
the package? I tried downloading the SRPM, but it's not tagged for x86_64. Do I
just throw in a --target=i386? What about i386 *-devel packages?

Comment 4 Andreas Bierfert 2006-04-03 12:02:16 UTC
Should be fixed in 0.9.11 release... please reopen if you still have problems
with this.

Comment 5 Gen Zhang 2006-04-03 18:46:49 UTC
Sorry, but I don't seem to see any change here... Tried regenerating .wine by
removing it and re-running wineprefixcreate, but it didn't make any difference
either.

Comment 6 Andreas Bierfert 2006-04-03 20:44:26 UTC
even with 0.9,11... that indeed is strange...
I don't have a clue... could you attach a screenshot (or mail me direct?) thanks

Comment 7 Gen Zhang 2006-04-03 21:48:15 UTC
Created attachment 127261 [details]
screenshot of winecfg

Comment 8 Gen Zhang 2006-04-03 21:49:27 UTC
Created attachment 127262 [details]
screenshot of firefox

Comment 9 Gen Zhang 2006-04-04 10:00:32 UTC
I've just realised that I never said I'm on amd64... but should that even
matter? This also relates to the question about building from src earlier.

Comment 10 Andreas Bierfert 2006-04-04 10:23:37 UTC
No that should indeed not matter... I am on x86_64 myself...

Comment 11 Gen Zhang 2006-04-04 11:10:31 UTC
Then may I ask how you are generating the i386 rpms from the srpm posted in the
extras repos? Currently I can't do rpmbuild on them because I don't have i386
devel packages.

Comment 12 Andreas Bierfert 2006-04-04 11:12:13 UTC
Well actually I don't on that box (but you can always use mock for that as
well). I do testbuilds on my i386 and the buildsystem does the same...

Comment 13 Gen Zhang 2006-04-25 08:54:33 UTC
Still seeing it with 0.9.12... Am I alone in seeing this?

Comment 14 Gen Zhang 2006-05-18 19:06:01 UTC
Appears to be fixed. What changed?

Comment 15 Andreas Bierfert 2006-05-18 22:28:32 UTC
Nothing on my end +)... thanks for the reply.


Note You need to log in before you can comment on or make changes to this bug.