Bug 187547 - build failure when including jawt_md.h
build failure when including jawt_md.h
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
: Reopened
Depends On:
Blocks: 234547
  Show dependency treegraph
 
Reported: 2006-03-31 15:36 EST by Thomas Fitzsimmons
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.2.8-1jpp.1.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 22:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failing C source file. (2.00 KB, text/x-csrc)
2006-03-31 15:36 EST, Thomas Fitzsimmons
no flags Details

  None (edit)
Description Thomas Fitzsimmons 2006-03-31 15:36:46 EST
The attached source file fails to build against the latest RHEL4 x86-64 IBM JVM:

$ gcc -O2 -Wall -DSWT_VERSION=3139  -DLINUX -DGTK -I/usr/lib/jvm/java/include
-I/usr/lib/jvm/java/include/linux -fpic -DSWT_PTR_SIZE_64   -c -o swt_awt.o
swt_awt.c
In file included from /usr/lib/jvm/java/include/jawt_md.h:46,
                 from swt_awt.c:12:
/usr/lib/jvm/java/include/jawt.h:301: error: syntax error before "jboolean"

$ java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 2.2)
IBM J9SE VM (build 2.2, J2RE 1.4.2 IBM J9 2.2 Linux amd64-64 j9xa64142-20050929
(JIT enabled)
J9VM - 20050915_1103_LHdSMr
JIT  - r7_level20050909_1801)

$ rpm -q java-1.4.2-ibm java-1.4.2-ibm-devel
java-1.4.2-ibm-1.4.2.3-1jpp_14rh
java-1.4.2-ibm-devel-1.4.2.3-1jpp_14rh
Comment 1 Thomas Fitzsimmons 2006-03-31 15:36:46 EST
Created attachment 127152 [details]
Failing C source file.
Comment 2 IBM Bug Proxy 2006-04-05 17:19:05 EDT
----- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2006-04-05 17:20 EDT -------
I\'lI tried the testcase on a RHEL 4 U3 x86 box and it worked fine so I started
comparing the devel packages for x86 and X86_64.

The two jawt*.h header files are identical between the ones in the X86_64 and
the x86 devel packages The jni.h that jawt.h include unfortunetly are not and
X86_64 version seems to be missing the following:

#ifdef _JNI_IMPLEMENTATION_
#define _JNI_IMPORT_OR_EXPORT_ JNIEXPORT_PROTOTYPE                    /*ibm.54*/
#else
#define _JNI_IMPORT_OR_EXPORT_ JNIIMPORT
#endif

The \"/usr/lib/jvm/java/include/jawt.h:301: error: syntax error before
\"jboolean\"\" is complaining about the _JNI_IMPORT_OR_EXPORT_ which doesn\'t exist.

I\'m going to grab the Java 1.4.2 SR4 package and see what it contains. 
Comment 3 IBM Bug Proxy 2006-04-07 10:28:47 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
        Owning Team|LTC Internal Support        |JTC
          Reference|                            |35801,001,866




------- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2006-04-07 10:30 EDT -------
I created PMR 35801,001,866 to report the problem to the Java support folks
since SR4 jni.h is still missing the definition. 
Comment 4 Thomas Fitzsimmons 2006-06-30 09:42:09 EDT
This is fixed in the latest 1.4.2 drop from IBM, which will be released with
RHEL4U5.
Comment 5 IBM Bug Proxy 2006-09-12 15:55:53 EDT
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-09-12 15:54 EDT -------
Java 1.4.2 SR6 is now available so whenever the next update of RHEL comes about
and SR6 hopefully is picked up we can likely close this. 
Comment 6 Thomas Fitzsimmons 2006-10-30 15:40:12 EST
I built java-1.4.2-ibm-1.4.2.6-1jpp.2.el4 into dist-4E-lacd-qu-candidate. 
Changing to MODIFIED.
Comment 7 Thomas Fitzsimmons 2006-10-30 15:48:23 EST
Proposing for RHEL-4.5.
Comment 8 RHEL Product and Program Management 2006-10-30 16:06:13 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 IBM Bug Proxy 2006-11-30 12:15:41 EST
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-11-30 12:13 EDT -------
Thomas, 

I revisted this bug with IBM Java SDK 1.4.2 SR6 for x86_64 and I still get the
original error of:

In file included from /root/IBMJava2-amd64-142/include/jawt_md.h:46,
                 from swt_awt.c:12:
/root/IBMJava2-amd64-142/include/jawt.h:301: error: syntax error before "jboolean"

so I am wondering in one comment you mention the latest drop from IBM fixed it.
What who that have been? 
Comment 12 IBM Bug Proxy 2006-11-30 12:50:49 EST
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-11-30 12:45 EDT -------
From what I can tell the fix may show up in SR7 though I am trying to confirm. 
Comment 13 IBM Bug Proxy 2006-12-01 09:40:44 EST
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-12-01 09:36 EDT -------
I received confirmation from the Java team that the fix for this problem is in
SR7 which is not yet available. 
Comment 14 Thomas Fitzsimmons 2006-12-01 14:23:59 EST
OK, pushing this to RHEL-4.6.
Comment 15 Thomas Fitzsimmons 2006-12-18 11:40:06 EST
Re-assigning to myself.  I'll change the status back to MODIFIED once I've
received and packaged the SR7 drop from IBM.
Comment 16 RHEL Product and Program Management 2006-12-18 11:41:00 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 19 IBM Bug Proxy 2007-01-26 10:21:13 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED




------- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2007-01-26 10:15 EDT -------
Since Java 1.4.2 SR7 is already publically available and we've verified on our
side that the missing #define is fixed in SR7, I don't see any reason to keep
this bug open on the IBM side any longer. Closing... 

Note You need to log in before you can comment on or make changes to this bug.