Bug 1875491 - Listener creation failed because no LoadBalancer found
Summary: Listener creation failed because no LoadBalancer found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1878725
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-03 15:28 UTC by rlobillo
Modified: 2020-10-27 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:37:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
kuryr-controller logs (57.72 KB, text/plain)
2020-09-03 15:28 UTC, rlobillo
no flags Details
NP results for verification (188.58 KB, application/gzip)
2020-09-17 16:29 UTC, rlobillo
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 343 0 None closed Bug 1875491:Clean lb crd status upon Load Balancer removal 2020-09-15 11:41:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:04 UTC

Description rlobillo 2020-09-03 15:28:36 UTC
Created attachment 1713641 [details]
kuryr-controller logs

Description of problem:

While running NP, below exception appears on kuryr-controller:

2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2 [-] Listener creation failed, most probably because protocol TCP is not supported: openstack.exceptions.ResourceNotFound: No LoadBalancer found for 8fa6ce23-7385-40dd-8eb0-deb46ade2a1d: Client Error for url: https://10.46.22.71:13876/v2.0/lbaas/loadbalancers/8fa6ce23-7385-40dd-8eb0-deb46ade2a1d, Not Found
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2 Traceback (most recent call last):
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/lbaasv2.py", line 342, in ensure_listener
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     self._find_listener, _LB_STS_POLL_SLOW_INTERVAL)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/lbaasv2.py", line 668, in _ensure_provisioned
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     self._wait_for_provisioning(loadbalancer, remaining, interval)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/lbaasv2.py", line 698, in _wait_for_provisioning
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     response = lbaas.get_load_balancer(loadbalancer['id'])
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/load_balancer/v2/_proxy.py", line 58, in get_load_balancer
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     return self._get(_lb.LoadBalancer, *attrs)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/proxy.py", line 46, in check
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     return method(self, expected, actual, *args, **kwargs)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/proxy.py", line 508, in _get
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     resource_type=resource_type.__name__, value=value))
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/resource.py", line 1416, in fetch
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     self._translate_response(response, **kwargs)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/resource.py", line 1113, in _translate_response
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     exceptions.raise_from_response(response, error_message=error_message)
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2   File "/usr/lib/python3.6/site-packages/openstack/exceptions.py", line 235, in raise_from_response
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2     http_status=http_status, request_id=request_id
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2 openstack.exceptions.ResourceNotFound: No LoadBalancer found for 8fa6ce23-7385-40dd-8eb0-deb46ade2a1d: Client Error for url: https://10.46.22.71:13876/v2.0/lbaas/loadbalancers/8fa6ce23-7385-40dd-8eb0-deb46ade2a1d, Not Found
2020-09-03 11:18:01.072 1 ERROR kuryr_kubernetes.controller.drivers.lbaasv2


Version-Release number of selected component (if applicable):
OCP4.6.0-0.nightly-2020-09-03-063148

How reproducible: 


Steps to Reproduce:
1. Install latest OCP.6 over OSP16.1 (ovn-octavia)
2. Run NP tests.
3.

Actual results: 


Expected results: No exception like that should be observed.


Additional info: kuryr-controller logs attached.

Comment 2 rlobillo 2020-09-17 16:28:28 UTC
Verified on 4.6.0-0.nightly-2020-09-17-073141 over OSP RHOS-16.1-RHEL-8-20200903.n.0

NP test run with expected results. No exceptions observed:

[stack@undercloud-0 ~]$ oc get pods -n openshift-kuryr
NAME                                READY   STATUS    RESTARTS   AGE
kuryr-cni-7869s                     1/1     Running   0          3h17m
kuryr-cni-7lgg6                     1/1     Running   0          3h16m
kuryr-cni-n6lwn                     1/1     Running   0          3h14m
kuryr-cni-v4ccn                     1/1     Running   0          3h17m
kuryr-cni-wdnxk                     1/1     Running   0          3h15m
kuryr-cni-xkvcr                     1/1     Running   0          3h14m
kuryr-controller-66469ccbb9-bbmph   1/1     Running   1          173m
[stack@undercloud-0 ~]$ oc logs -n openshift-kuryr kuryr-controller-66469ccbb9-bbmph | grep "No LoadBalancer found"
[stack@undercloud-0 ~]$ oc logs -n openshift-kuryr kuryr-controller-66469ccbb9-bbmph -p | grep "No LoadBalancer found"

Attaching NP results.

Comment 3 rlobillo 2020-09-17 16:29:50 UTC
Created attachment 1715251 [details]
NP results for verification

Comment 6 errata-xmlrpc 2020-10-27 16:37:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.