Bug 187554 - umount fails to unmount ISO image with spaces in path on system shutdown
Summary: umount fails to unmount ISO image with spaces in path on system shutdown
Status: CLOSED DUPLICATE of bug 186713
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-31 21:11 UTC by Peter Klotz
Modified: 2014-03-17 02:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 21:23:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Klotz 2006-03-31 21:11:00 UTC
Description of problem:
I have the following line in my /etc/fstab file to mount the Fedora Core 5 ISO
image on startup using the loopback device:

/root/Fedora\040Core/5/i386/iso/FC-5-i386-DVD.iso /mnt/Fedora\040Core/5/i386
iso9660 loop,ro 0 0

Spaces in both paths are escaped with \040.

Mounting of the image when booting the system works without problems but on
shutdown lots of error messages appear indicating that unmounting the image
failed. The problem comes from /etc/rc.d/init.d/halt.

Version-Release number of selected component (if applicable): 8.31.1-1

How reproducible:
Always

Steps to Reproduce:
1. Boot the system. The ISO images gets mounted as expected.
2. Shutdown or reboot the system.
3. One obtains messages like: umount: /mnt/Fedora\040Core/5/i386: not found
  
Actual results:
Umounting fails with a lot of error messages.

Expected results:
Umount should succeed.

Additional info:

Comment 1 Bill Nottingham 2006-04-03 21:23:57 UTC

*** This bug has been marked as a duplicate of 186713 ***


Note You need to log in before you can comment on or make changes to this bug.