Bug 187567 - Anaconda and yumex crashes when Turkish support is selected
Anaconda and yumex crashes when Turkish support is selected
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 18:39 EST by Devrim GÜNDÜZ
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 09:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devrim GÜNDÜZ 2006-03-31 18:39:26 EST
Description of problem:
If we want to install Fedora Core with Turkish Language Support, anaconda
crashes. Same happens in yumex.

Version-Release number of selected component (if applicable):
Fedora Core 5, with

How reproducible:
Always.

Steps to Reproduce:
1. Begin installation and click "Turkish Support" on "Languages"
2. ... or do the same in yumex
  
Actual results:
Here is one of the problems in Yumex:
====================================
Component: yumex
Version: 0.99.15
Summary: TBe13078f4 yumexmain.py:403:on_group_popup:UnboundLocalError: local
variable 'msg' referenced before assignment

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 403, in on_group_popup
    self.yumexbase.log(2,msg % no)
UnboundLocalError: local variable 'msg' referenced before assignment

Local variables in innermost frame:
grp: Turkish Support
iterator: <GtkTreeIter at 0xd6fb3e8>
no: 0
self: <__main__.YumexMainApplication instance at 0xb79be26c>
label: _Add to Queue
state: 2
pkgs: []
model: <gtk.TreeStore object (GtkTreeStore) at 0xb79cc48c>
====================================
Expected results:
Both operations should not fail.

Additional info:
I think we cannot fix the anaconda bug (it's too late now), but we can fix the
problem in Yumex.
Comment 1 Tim Lauridsen 2006-04-10 03:00:32 EDT
I will take a deeper look at this traceback
Comment 2 Tim Lauridsen 2006-04-10 06:00:11 EDT
The trackback occurs because 'Add to Queue' is clicked twice, this is fixed now.
But this is not the main issue, You cant install 'Turkish Support' because the
group only contains only "conditional' packages. And the current yumex release
0.99.16 dont support this.

Read more here:
https://lists.dulug.duke.edu/pipermail/yum-devel/2006-February/001896.html

I have added support for conditional packages in groups in yumex 0.99.17, so the
conditional packages is added as default packages if the requirement is installed.
It will be released soon.

Note You need to log in before you can comment on or make changes to this bug.