Bug 18757 - Installation of RH7.0 fails during format of swap
Installation of RH7.0 fails during format of swap
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 19:08 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 04:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-09 19:08:18 EDT
Installation of RH7.0 from CD-ROM fails just after or during formatting  of
the swap partition while using the expert mode.  I am able to get past this
point and do a complete install under the workstation class, but would
really like to be able to go though and install many of the other
individual packages at this time (only allowed under expert mode).

Please let me know if there is something that I can do to get this to work
properly...till that time I am stuck with MSwindows on this machine.

Thanks much, Andy

-------------------------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Marian-Nicolae ION 2000-10-10 04:45:31 EDT
I've encountered the same problem - I wanted to install Linux on /dev/hdb2 and
/dev/hda is occupied with Windows & BeOS. I've made that disk primary (temporary
disabling the "old" primary, the former /dev/hda) and thus RH7 has successfully
been installed on /dev/hda2. Then I've modified /etc/fstab, halted the system,
reinserted the primary, changed the RH partitioned disk to secondary and thus
I've managed to have both RH7 on /dev/hdb2 AND /dev/hda with its Windows & BeOS
partitions.
Comment 2 Daniel Roesen 2000-10-10 04:46:51 EDT

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.