Bug 187570 - metacity crashes on shutdown
metacity crashes on shutdown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 20:35 EST by David Baron
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 15:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Baron 2006-03-31 20:35:54 EST
Description of problem:  metacity crashes on shutdown, I think pretty much every
time I log out.  The only symptom is that it leaves a core file (and that only
because I have coredumpsize unlimited.)

Version-Release number of selected component (if applicable):
metacity-2.14.0-1

How reproducible:  Always, I think.

Steps to Reproduce:
1. create an .Xclients with:

#!/bin/bash
ulimit -c unlimited
exec /etc/X11/init/Xclients

2. log in to GNOME
3. log out
  
Actual results: metacity generates a core file

Expected results: no core file

Additional info:

The stack is:

#0  meta_compositor_unref (compositor=0x0) at compositor.c:162
#1  0x0805e020 in meta_display_close (display=0x8ae4100) at display.c:926
#2  0x0807086c in main (argc=1, argv=0xbfe4a274) at main.c:505
#3  0x00f617e4 in __libc_start_main (main=0x8070100 <main>, argc=3,
    ubp_av=0xbfe4a274, init=0x80aeafc <__libc_csu_init>,
    fini=0x80aeaf4 <__libc_csu_fini>, rtld_fini=0x34ee40 <_dl_fini>,
    stack_end=0xbfe4a26c) at libc-start.c:231
#4  0x08053bb1 in _start ()

which indicates that this is a problem in the metacity-2.13.144-bling.patch that
is being applied by the FC5 distribution.  All other uses of display->compositor
seem to be null-checked (as applying that patch requires), but the line:
display.c:926       meta_compositor_unref (display->compositor);
is not surrounded by a null-check of display->compositor.  Fixing this patch to
add a null-check seems like the right fix, although I haven't tested it.

Note You need to log in before you can comment on or make changes to this bug.