Bug 1875809 - Topology - Improve Pipeline Run & Build Duration Text
Summary: Topology - Improve Pipeline Run & Build Duration Text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Abhinandan Das
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-04 12:35 UTC by Abhinandan Das
Modified: 2020-10-27 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:37:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6493 0 None closed Bug 1875809: Restyle Time to inlineblock for Topology - Pipeline & Builds 2020-09-23 10:33:42 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:06 UTC

Description Abhinandan Das 2020-09-04 12:35:37 UTC
Description
When viewing the sidebar in Topology, the Builds and Pipeline Runs show their "id" on the running object and in brackets how long ago it started.

The duration (how long ago) should be a inline-block content and show up on it's own line if it's unable to show on one line.

version:
4.6

Steps to Reproduce
1. Add a Pipeline to a Deployment
2. Fire up a few Pipeline Runs over some duration

Actual result:
 The time is displayed as an inline and breaks desired UX

Expectecd result
The time should be displayed as inline block.

Comment 2 Abhinandan Das 2020-09-23 10:36:47 UTC
Verified on

OpenShift Version
4.6.0-0.nightly-2020-09-22-213802
Kubernetes Version
v1.19.0+8a39924
Channel
stable-4.6
Cluster ID
f121c7e0-cc7c-4d86-9b19-b10233391c34
API Server
https://api.jakumar-22091122.devcluster.openshift.com:6443

Comment 5 errata-xmlrpc 2020-10-27 16:37:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.