Bug 1875828 - My builtin keyboard and touchpad stop working on Asus Zenbook3 on kernel-5.8.4
Summary: My builtin keyboard and touchpad stop working on Asus Zenbook3 on kernel-5.8.4
Keywords:
Status: CLOSED DUPLICATE of bug 1876997
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-04 13:25 UTC by Martin Vala
Modified: 2020-09-21 09:13 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-16 16:29:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Vala 2020-09-04 13:25:27 UTC
1. Please describe the problem:
After upgrade from kernel-5.7.17 to kernel-5.8.4 my builtin keyboard and touchpad stop working. Asus Zenbook3

2. What is the Version-Release number of the kernel:
kernel-5.8.4

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Yes is was working on kernel-5.7.17

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:


6. Are you running any modules that not shipped with directly Fedora's kernel?:


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Felix 2020-09-06 13:33:56 UTC
Same as the bug 1875339

Comment 2 Martin Vala 2020-09-16 06:52:22 UTC
Still not working with 5.8.8-200.fc32.x86_64

Comment 3 Hans de Goede 2020-09-16 07:01:40 UTC
Ugh, I'm afraid that this is likely my fault.

I added support for SW_TABLET_MODE to the asus-wmi kernel driver and the patch for that has landed in the 5.8 kernel.

Can you please run:

sudo dnf install evemu acpica-tools
evemu-record

And in evemu-record select the "Asus WMI hotkeys" device?

I expect that with the 5.8 kernel, you will see that that input device has a SW_TABLET_MODE switch and that that switch reports 1.

This causes libinput to think that the device is a 2-in-1 with 360 degree (yoga style) hinges which has been folded into tablet-mode and then it suppresses kbds and touchpad events for the internal kbd and touchpad.

If there indeed is a SW_TABLET_MODE switch being reported and it always reports 1, please run:

sudo acpidump -o acpidump-asus-zenbook3

And than attach the acpidump-asus-zenbook3 file here?

Comment 4 Felix 2020-09-16 08:43:35 UTC
evemu-record see Asus MI hotkeys, but nothing change. SW_TABLET_MODE dont return nothing

[root@localhost felixelens]# acpidump -o acpidump-asus-R558U
Target path already exists, overwrite? [y|n] y
[root@localhost felixelens]# 

nothing happen ...

root@localhost felixelens]# acpidump -o acpidump-asus-zenbook3
[root@localhost felixelens]# 

nothing happen...


you can see nothing happen... good day to you.

Comment 5 Felix 2020-09-16 09:51:56 UTC
SW_TABLET_MODE is 1, but nothing change, no keyboard and pad...

Comment 6 Hans de Goede 2020-09-16 13:09:38 UTC
The acpidump command generates the file named by the "-o <filename>" option, please attach that file here for all Asus models you have access to.

Comment 7 Hans de Goede 2020-09-16 13:15:18 UTC
Also please provide the output of the following command run as a regular user:

grep . /sys/class/dmi/id/* 2> /dev/null

Comment 8 Hans de Goede 2020-09-16 16:26:12 UTC
I've started a kernel test-build with a patch added which fix this:

https://koji.fedoraproject.org/koji/taskinfo?taskID=51598665

ATM this is still building (this takes a couple of hours). Once the build is finished please give this kernel a try. As soon as I've confirmation that the patch indeed fixes things I will submit it for inclusion into the Fedora kernels (as a downstream patch for now).

See here for some generic instructions on how to test a kernel directly from koji (our buildsystem):
https://fedorapeople.org/~jwrdegoede/kernel-test-instructions.txt

Comment 9 Hans de Goede 2020-09-16 16:29:58 UTC
This bug is currently being tracked in more then one bugzilla. Most of the initial debugging has been done in bug 1876997, so I'm marking this one as a duplicate of that bug.

Please add any new comments / test findings there.

*** This bug has been marked as a duplicate of bug 1876997 ***

Comment 10 Felix 2020-09-17 12:14:28 UTC
Every think work perfectly now. No more bug , thank too you all

Comment 11 Martin Vala 2020-09-21 09:13:31 UTC
Working fine for me. Thank you very much


Note You need to log in before you can comment on or make changes to this bug.