Bug 1875855 - [OSP] Ignition cannot download bootstrap config from Glance because of timeout
Summary: [OSP] Ignition cannot download bootstrap config from Glance because of timeout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
: 1884048 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-04 14:40 UTC by Mike Fedosin
Modified: 2020-10-27 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:37:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4145 0 None closed Bug 1875855: increase timeout for bootstrap ignition downloading 2021-02-19 08:10:54 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:11 UTC

Description Mike Fedosin 2020-09-04 14:40:33 UTC
Description of problem:

In some OpenStack environments, fetching of bootstrap ignition config from Glance can take a long time, so the installation ends unsuccessfully.

Current timeout is set to 10 seconds, but sometimes the storage is taking 18 seconds or more. To prevent this we need to set higher timeout for the bootstrap config.

Comment 3 David Sanz 2020-09-10 12:01:26 UTC
Verified

Comment 4 Martin André 2020-10-01 09:24:30 UTC
*** Bug 1884048 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-10-27 16:37:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.