Bug 1875878 - pipeline logs scroll issues
Summary: pipeline logs scroll issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Mohammed Saud
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-04 15:39 UTC by Mohammed Saud
Modified: 2020-10-27 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-01-202952 Cluster ID: ca42b0c6-8d99-4703-8a0f-865b092c873b Browser: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0
Last Closed: 2020-10-27 16:37:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
pipeline logs do not have scroll issues (3.20 MB, video/webm)
2020-09-23 22:56 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6535 0 None closed Bug 1875878: Move pipelinerun log scroll handler to parent element 2020-09-23 08:40:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:11 UTC

Description Mohammed Saud 2020-09-04 15:39:21 UTC
Description of problem:

When streaming pipeline logs, the log view inefficiently scrolls and doesn't stick to the bottom of the content. At times the logs even fail to scroll.

Furthermore once the user scrolls away from the bottom and is viewing a portion of the log, the log continues to force the user to the bottom instead of letting the user remain at their current scroll position. This makes it hard to read the logs while they are streaming.
Prerequisites (if any, like setup, operators/versions):

install pipelines

setup petclinic tutorial
Steps to Reproduce

    start a pipeline run
    open the logs view

Expected:

If the user scrolls away from the bottom, the view should stop automatically scrolling.

When the user scrolls to the bottom, the view should constantly scroll to the bottom when new lines are added.

I expect the pods logs and pipeline logs to behave the sa

Comment 1 spathak@redhat.com 2020-09-23 22:56:25 UTC
Created attachment 1716170 [details]
pipeline logs do not have scroll issues

Comment 2 spathak@redhat.com 2020-09-23 22:57:47 UTC
Verify on build version: 4.6.0-0.nightly-2020-09-22-130743
Browser version: Chrome 84

Comment 5 errata-xmlrpc 2020-10-27 16:37:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.