Bug 187589 - unable to change video or difficulty settings
unable to change video or difficulty settings
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: abe (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 06:39 EST by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-02 18:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
enable changing the video settings in-game (336 bytes, patch)
2006-04-02 18:06 EDT, Wart
no flags Details | Diff

  None (edit)
Description Christopher Stone 2006-04-01 06:39:39 EST
Description of problem:  In abe's settings screen, I am unable to change
difficulty or video settings.  Changing the sound settings works fine.


Version-Release number of selected component (if applicable): 
abe-0:1.1-1.fc5.x86_64

How reproducible: run abe and try changing video settings or difficulty


Steps to Reproduce:
1. run abe
2. select settings
3. scroll down to difficulty or video settings
4. pressing space bar does not change settings
  
Actual results:  Pressing space bar should change settings


Expected results:  Settings changed


Additional info: None
Comment 1 Wart 2006-04-01 18:16:21 EST
I verified that this happens on FC4 as well.  I'm looking into the cause of the
problem now.
Comment 2 Hans de Goede 2006-04-02 14:35:17 EDT
Michael let me know if you want me to take a look, happy bug hunting!
Comment 3 Wart 2006-04-02 16:40:40 EDT
I found the culprit.  The event handler to handle settings changes is ignoring
everything but the sound settings.  The fix looks like it will be pretty easy.
Comment 4 Wart 2006-04-02 18:06:53 EDT
Created attachment 127214 [details]
enable changing the video settings in-game

This has to be the smallest fix I've ever made: one bit.  A build for the devel
branch is on the way.  FC-4,5 builds will come shortly after.

Note You need to log in before you can comment on or make changes to this bug.